Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Grant Negotiation and Authorization Protocol (GNAP) Created 2024-03-21 Last Updated 2025-04-25 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • GNAP Grant Request Parameters • GNAP Access Token Flags • GNAP Subject Information Request Fields • GNAP Assertion Formats • GNAP Client Instance Fields • GNAP Client Instance Display Fields • GNAP Interaction Start Modes • GNAP Interaction Finish Methods • GNAP Interaction Hints • GNAP Grant Response Parameters • GNAP Interaction Mode Responses • GNAP Subject Information Response Fields • GNAP Error Codes • GNAP Key Proofing Methods • GNAP Key Formats • GNAP Authorization Server Discovery Fields • GNAP Token Formats • GNAP Token Introspection Request • GNAP Token Introspection Response • GNAP Resource Set Registration Request Parameters • GNAP Resource Set Registration Response Parameters • GNAP RS-Facing Discovery Document Fields • GNAP RS-Facing Error Codes GNAP Grant Request Parameters Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Type Reference access_token object [RFC 9635, Section 2.1.1] access_token array of objects [RFC 9635, Section 2.1.2] subject object [RFC 9635, Section 2.2] client object [RFC 9635, Section 2.3] client string [RFC 9635, Section 2.3.1] user object [RFC 9635, Section 2.4] user string [RFC 9635, Section 2.4.1] interact object [RFC 9635, Section 2.5] interact_ref string [RFC 9635, Section 5.1] existing_access_token string [RFC 9767, Section 4] GNAP Access Token Flags Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Allowed Use Reference bearer Request, Response [RFC 9635, Section 2.1.1, 3.2.1] durable Response [RFC 9635, Section 3.2.1] GNAP Subject Information Request Fields Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Type Reference sub_id_formats array of strings [RFC 9635, Section 2.2] assertion_formats array of strings [RFC 9635, Section 2.2] sub_ids array of objects [RFC 9635, Section 2.2] GNAP Assertion Formats Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Reference id_token [RFC 9635, Section 3.4.1] saml2 [RFC 9635, Section 3.4.1] GNAP Client Instance Fields Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Type Reference key object [RFC 9635, Section 7.1] key string [RFC 9635, Section 7.1.1] class_id string [RFC 9635, Section 2.3] display object [RFC 9635, Section 2.3.2] GNAP Client Instance Display Fields Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Type Reference name string [RFC 9635, Section 2.3.2] uri string [RFC 9635, Section 2.3.2] logo_uri string [RFC 9635, Section 2.3.2] GNAP Interaction Start Modes Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Mode Type Reference redirect string [RFC 9635, Section 2.5.1.1] app string [RFC 9635, Section 2.5.1.2] user_code string [RFC 9635, Section 2.5.1.3] user_code_uri string [RFC 9635, Section 2.5.1.4] GNAP Interaction Finish Methods Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Method Reference redirect [RFC 9635, Section 2.5.2.1] push [RFC 9635, Section 2.5.2.2] GNAP Interaction Hints Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Reference ui_locales [RFC 9635, Section 2.5.3] GNAP Grant Response Parameters Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Type Reference continue object [RFC 9635, Section 3.1] access_token object [RFC 9635, Section 3.2.1] access_token array of objects [RFC 9635, Section 3.2.2] interact object [RFC 9635, Section 3.3] subject object [RFC 9635, Section 3.4] instance_id string [RFC 9635, Section 3.5] error object [RFC 9635, Section 3.6] GNAP Interaction Mode Responses Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Reference redirect [RFC 9635, Section 3.3] app [RFC 9635, Section 3.3] user_code [RFC 9635, Section 3.3] user_code_uri [RFC 9635, Section 3.3] finish [RFC 9635, Section 3.3] expires_in [RFC 9635, Section 3.3] GNAP Subject Information Response Fields Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Type Reference sub_ids array of objects [RFC 9635, Section 3.4] assertions array of objects [RFC 9635, Section 3.4] updated_at string [RFC 9635, Section 3.4] GNAP Error Codes Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Error Reference invalid_request [RFC 9635, Section 3.6] invalid_client [RFC 9635, Section 3.6] invalid_interaction [RFC 9635, Section 3.6] invalid_flag [RFC 9635, Section 3.6] invalid_rotation [RFC 9635, Section 3.6] key_rotation_not_supported [RFC 9635, Section 3.6] invalid_continuation [RFC 9635, Section 3.6] user_denied [RFC 9635, Section 3.6] request_denied [RFC 9635, Section 3.6] unknown_interaction [RFC 9635, Section 3.6] unknown_user [RFC 9635, Section 3.6] too_fast [RFC 9635, Section 3.6] too_many_attempts [RFC 9635, Section 3.6] GNAP Key Proofing Methods Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Method Type Reference httpsig string [RFC 9635, Section 7.3.1] httpsig object [RFC 9635, Section 7.3.1] mtls string [RFC 9635, Section 7.3.2] jwsd string [RFC 9635, Section 7.3.3] jws string [RFC 9635, Section 7.3.4] GNAP Key Formats Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Format Reference jwk [RFC 9635, Section 7.1] cert [RFC 9635, Section 7.1] cert#S256 [RFC 9635, Section 7.1] GNAP Authorization Server Discovery Fields Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9635] Available Formats [IMG] CSV Name Type Reference grant_request_endpoint string [RFC 9635, Section 9] interaction_start_modes_supported array of strings [RFC 9635, Section 9] interaction_finish_methods_supported array of strings [RFC 9635, Section 9] key_proofs_supported array of strings [RFC 9635, Section 9] sub_id_formats_supported array of strings [RFC 9635, Section 9] assertion_formats_supported array of strings [RFC 9635, Section 9] key_rotation_supported boolean [RFC 9635, Section 9] GNAP Token Formats Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9767] Available Formats [IMG] CSV Name Status Description Reference jwt-signed Active JSON Web Token, signed with JWS [RFC 7519] jwt-encrypted Active JSON Web Token, encrypted with JWE [RFC 7519] macaroon Active Macaroon [MACAROON] biscuit Active Biscuit [BISCUIT] zcap Active ZCAP [ZCAPLD] GNAP Token Introspection Request Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9767] Available Formats [IMG] CSV Name Type Reference access_token string [RFC 9767, Section 3.3] proof string [RFC 9767, Section 3.3] resource_server object/string [RFC 9767, Section 3.3] access array of strings/objects [RFC 9767, Section 3.3] GNAP Token Introspection Response Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9767] Available Formats [IMG] CSV Name Type Reference active boolean [RFC 9767, Section 3.3] access array of strings/objects [RFC 9767, Section 3.3] key object/string [RFC 9767, Section 3.3] flags array of strings [RFC 9767, Section 3.3] exp integer [RFC 9767, Section 3.3] iat integer [RFC 9767, Section 3.3] nbf integer [RFC 9767, Section 3.3] aud string or array of strings [RFC 9767, Section 3.3] sub string [RFC 9767, Section 3.3] iss string [RFC 9767, Section 3.3] instance_id string [RFC 9767, Section 3.3] GNAP Resource Set Registration Request Parameters Registration Procedure(s) Expert Review Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9767] Available Formats [IMG] CSV Name Type Reference access array of strings/objects [RFC 9767, Section 3.4] resource_server object/string [RFC 9767, Section 3.4] token_formats_supported array of strings [RFC 9767, Section 3.4] token_introspection_required boolean [RFC 9767, Section 3.4] GNAP Resource Set Registration Response Parameters Registration Procedure(s) Expert Review Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9767] Available Formats [IMG] CSV Name Type Reference resource_reference string [RFC 9767, Section 3.4] instance_id string [RFC 9767, Section 3.4] introspection_endpoint string [RFC 9767, Section 3.4] GNAP RS-Facing Discovery Document Fields Registration Procedure(s) Expert Review Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9767] Available Formats [IMG] CSV Name Type Reference introspection_endpoint string [RFC 9767, Section 3.1] token_formats_supported array of strings [RFC 9767, Section 3.1] resource_registration_endpoint string [RFC 9767, Section 3.1] grant_request_endpoint string [RFC 9767, Section 3.1] key_proofs_supported array of strings [RFC 9767, Section 3.1] GNAP RS-Facing Error Codes Registration Procedure(s) Specification Required Expert(s) Justin Richer, Joseph Salowey, Sudesha Shetty Reference [RFC 9767] Available Formats [IMG] CSV Error Reference invalid_request [RFC 9767, Section 3.5] invalid_resource_server [RFC 9767, Section 3.5] invalid_access [RFC 9767, Section 3.5] Licensing Terms