Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Hypertext Transfer Protocol (HTTP) Authentication Scheme Registry Created 2014-02-17 Last Updated 2025-02-18 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • HTTP Authentication Schemes • HTTP Mutual Authentication Algorithms HTTP Authentication Schemes Registration Procedure(s) IETF Review Reference [RFC 9110, Section 16.4.1] Available Formats [IMG] CSV Authentication Scheme Name Reference Notes Basic [RFC 7617] Bearer [RFC 6750] Concealed [RFC 9729] Digest [RFC 7616] DPoP [RFC 9449, Section 7.1] GNAP [RFC 9635, Section 7.2] The HOBA scheme can be used with either HTTP servers or proxies. When used in response to a 407 HOBA [RFC 7486, Section 3] Proxy Authentication Required indication, the appropriate proxy authentication header fields are used instead, as with any other HTTP authentication scheme. Mutual [RFC 8120] Negotiate [RFC 4559, Section 3] This authentication scheme violates both HTTP semantics (being connection-oriented) and syntax (use of syntax incompatible with the WWW-Authenticate and Authorization header field syntax). OAuth [RFC 5849, Section 3.5.1] PrivateToken [RFC 9577, Section 2] SCRAM-SHA-1 [RFC 7804] SCRAM-SHA-256 [RFC 7804] vapid [RFC 8292, Section 3] HTTP Mutual Authentication Algorithms Registration Procedure(s) Expert Review Expert(s) Rifaat Shekh-Yusef, Yutaka Oiwa Reference [RFC 8120] Available Formats [IMG] CSV Token Description Reference Change Controller iso-kam3-dl-2048-sha256 ISO-11770-4 KAM3, 2048-bit DL [RFC 8121] IESG iso-kam3-dl-4096-sha512 ISO-11770-4 KAM3, 4096-bit DL [RFC 8121] IESG iso-kam3-ec-p256-sha256 ISO-11770-4 KAM3, 256-bit EC [RFC 8121] IESG iso-kam3-ec-p521-sha512 ISO-11770-4 KAM3, 521-bit EC [RFC 8121] IESG Licensing Terms