Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Port Control Protocol (PCP) Parameters Created 2012-11-21 Last Updated 2016-05-11 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • PCP Opcodes • PCP Result Codes • PCP Options PCP Opcodes Expert(s) Dan Wing, Stuart Cheshire Reference [RFC 6887] Available Formats [IMG] CSV Range Registration Procedures 0-31, 127 Standards Action 32-63 Specification Required Value Description Reference 0 ANNOUNCE [RFC 6887] 1 MAP [RFC 6887] 2 PEER [RFC 6887] 3 AUTHENTICATION [RFC 7652] 4-63 Unassigned 64-95 Reserved [RFC 6887] 96-126 Reserved for Private Use [RFC 6887] 127 Reserved [RFC 6887] PCP Result Codes Expert(s) Dan Wing, Stuart Cheshire Reference [RFC 6887] Available Formats [IMG] CSV Range Registration Procedures 0-127, 255 Standards Action 128-191 Specification Required Value Name Description Reference 0 SUCCESS Success. [RFC 6887] 1 UNSUPP_VERSION The version number at the start of the PCP Request header is not recognized by this PCP server. This [RFC 6887] is a long lifetime error. [RFC 6887] describes PCP version 2. 2 NOT_AUTHORIZED The requested operation is disabled for this PCP client, or the PCP client requested an operation that [RFC 6887] cannot be fulfilled by the PCP server's security policy. This is a long lifetime error. 3 MALFORMED_REQUEST The request could not be successfully parsed. This is a long lifetime error. [RFC 6887] 4 UNSUPP_OPCODE Unsupported Opcode. This is a long lifetime error. [RFC 6887] 5 UNSUPP_OPTION Unsupported Option. This error only occurs if the Option is in the mandatory-to-process range. This is [RFC 6887] a long lifetime error. 6 MALFORMED_OPTION Malformed Option (e.g., appears too many times, invalid length). This is a long lifetime error. [RFC 6887] 7 NETWORK_FAILURE The PCP server or the device it controls are experiencing a network failure of some sort (e.g., has [RFC 6887] not obtained an External IP address). This is a short lifetime error. Request is well-formed and valid, but the server has insufficient resources to complete the requested operation at this time. For example, the NAT device cannot create more mappings at this time, is short 8 NO_RESOURCES of CPU cycles or memory, or is unable to handle the request due to some other temporary condition. The [RFC 6887] same request may succeed in the future. This is a system-wide error, different from USER_EX_QUOTA. This can be used as a catch- all error, should no other error message be suitable. This is a short lifetime error. 9 UNSUPP_PROTOCOL Unsupported transport protocol, e.g. SCTP in a NAT that handles only UDP and TCP. This is a long [RFC 6887] lifetime error. 10 USER_EX_QUOTA This attempt to create a new mapping would exceed this subscriber's port quota. This is a short [RFC 6887] lifetime error. The suggested external port and/or external address cannot be provided. This error MUST only be returned for: * MAP requests that included the PREFER_FAILURE Option (normal MAP requests will return 11 CANNOT_PROVIDE_EXTERNAL an available external port); * MAP requests for the SCTP protocol (PREFER_FAILURE is implied); * PEER [RFC 6887] requests. See [Section 13.2 of RFC 6887] for processing details. The error lifetime depends on the reason for the failure. The source IP address of the request packet does not match the contents of the PCP Client's IP Address 12 ADDRESS_MISMATCH field, due to an unexpected NAT on the path between the PCP client and the PCP-controlled NAT or [RFC 6887] firewall. This is a long lifetime error. The PCP server was not able to create the filters in this request. This result code MUST only be 13 EXCESSIVE_REMOTE_PEERS returned if the MAP request contained the FILTER Option. See Section 13.3 for processing information. [RFC 6887] This is a long lifetime error. 14 INITIATION The client includes this PCP result code in its request to the server for authentication. [RFC 7652] 15 AUTHENTICATION_REQUIRED This error response is sent to the client if EAP authentication is required. [RFC 7652] 16 AUTHENTICATION_FAILED This error response is sent to the client if EAP authentication failed. [RFC 7652] 17 AUTHENTICATION_SUCCEEDED This success response is sent to the client if EAP authentication succeeded. [RFC 7652] 18 AUTHORIZATION_FAILED This error response is sent to the client if EAP authentication succeeded but authorization failed. [RFC 7652] 19 SESSION_TERMINATED This PCP result code indicates to the partner that the PA session must be terminated. [RFC 7652] 20 UNKNOWN_SESSION_ID This error response is sent from the PCP server if there is no known PA session associated with the [RFC 7652] Session ID sent in the PA request or common PCP request from the PCP client. 21 DOWNGRADE_ATTACK_DETECTED This PCP result code indicates to the client that the server detected a downgrade attack. [RFC 7652] 22 AUTHENTICATION_REQUEST The server indicates to the client that the PA message contains an EAP request. [RFC 7652] 23 AUTHENTICATION_REPLY The client indicates to the server that the PA message contains an EAP response. [RFC 7652] 24 THIRD_PARTY_ID_UNKNOWN The provided identifier in a THIRD_PARTY_ID option is unknown/unavailable to the PCP server. This is a [RFC 7843] long lifetime error. 25 THIRD_PARTY_MISSING_OPTION This error occurs if both THIRD_PARTY and THIRD_PARTY_ID options are expected in a request but one [RFC 7843] option is missing. This is a long lifetime error. 26 UNSUPP_THIRD_PARTY_ID_LENGTH The received option length is not supported. This is a long lifetime error. [RFC 7843] 27-191 Unassigned 192-254 Reserved for Private Use [RFC 6887] 255 Reserved [RFC 6887] PCP Options Expert(s) Dan Wing, Stuart Cheshire Reference [RFC 6887] Note Values 0-127 are mandatory to process, and 128-255 are optional to process. Available Formats [IMG] CSV Range Registration Procedures 0-63, 127-191, 255 Standards Action 64-95, 192-223 Specification Required Value Name Purpose Valid for Opcodes Length May Appear in Maximum Occurrences Reference 0 Reserved [RFC 6887] Request. May Indicates the MAP or PEER request appear in response 1 THIRD_PARTY is for a host other than the host MAP, PEER 16 octets only if it 1 [RFC 6887] sending the PCP Option. appeared in the associated request. Request. May Indicates that the PCP server appear in response 2 PREFER_FAILURE should not create an alternative MAP 0 only if it 1 [RFC 6887] mapping if the suggested external appeared in the port and address cannot be mapped. associated request. Request. May appear in response As many as fit 3 FILTER Specifies a filter for incoming MAP 20 octets only if it within maximum PCP [RFC 6887] packets. appeared in the message size. associated request. 4 NONCE See [Section 5.3 of RFC 7652]. AUTHENTICATION 4 octets Request and 1 [RFC 7652] response. 5 AUTHENTICATION_TAG See [Section 5.4 of RFC 7652]. MAP, PEER, ANNOUNCE variable Request and 1 [RFC 7652] response. 6 PA_AUTHENTICATION_TAG See [Section 5.5 of RFC 7652]. AUTHENTICATION variable Request and 1 [RFC 7652] response. 7 EAP_PAYLOAD See [Section 5.6 of RFC 7652]. AUTHENTICATION variable Request and 1 [RFC 7652] response. Request and As many as fit 8 PRF See [Section 5.7 of RFC 7652]. AUTHENTICATION 4 octets response. within maximum PCP [RFC 7652] message size. Request and As many as fit 9 MAC_ALGORITHM See [Section 5.8 of RFC 7652]. AUTHENTICATION 4 octets response. within maximum PCP [RFC 7652] message size. 10 SESSION_LIFETIME See [Section 5.9 of RFC 7652]. AUTHENTICATION 4 octets Response. 1 [RFC 7652] 11 RECEIVED_PAK See [Section 5.10 of RFC 7652]. AUTHENTICATION 4 octets Request and 1 [RFC 7652] response. 12 ID_INDICATOR See [Section 5.11 of RFC 7652]. AUTHENTICATION variable Response. 1 [RFC 7652] Together with the THIRD_PARTY Request. May option, the THIRD_PARTY_ID option Variable; appear in response 13 THIRD_PARTY_ID identifies a third party for which MAP, PEER maximum 1016 only if it 1 [RFC 7843] a request for an external IP octets. appeared in the address and port is made. associated request. 14-95 Unassigned 96-126 Reserved for Private Use [RFC 6887] 127 Reserved [RFC 6887] Request. May variable, appear in response 128 DESCRIPTION Used to associate a text MAP, PEER maximum 1016 only if it 1 [RFC 7220] description with a mapping. octets. appeared in the associated request. Learn the prefix used by the NAT64 1 for a request. As to build IPv4-converted IPv6 many as fit within 129 PREFIX64 addresses. This is used by a host MAP, ANNOUNCE variable request, response the maximum PCP [RFC 7225] for local address synthesis (e.g., message size for a when an IPv4 address is present in response. referrals). 130 PORT_SET To map sets of ports. MAP 5 bytes Request and 1 [RFC 7753] response. 131-191 Unassigned 192 CHECKPOINT_REQUIRED Indicate if an entry needs to be MAP, PEER 0 Request and 1 [RFC 7767] check-pointed. response. 193-223 Unassigned 224-254 Reserved for Private Use [RFC 6887] 255 Reserved [RFC 6887] Licensing Terms