Internet Assigned Numbers Authority • Domains • Protocols • Numbers • About Protocol Independent Multicast (PIM) Parameters Last Updated 2026-08-27 Available Formats [IMG] XML [IMG] HTML [IMG] TXT Registries Included Below • PIM-Hello Options • PIM Join Attribute Types • PIM Address Family • PIM Address Encoding Types • PIM Message Types • PORT Message Types • PORT Option Types • PIM Join/Prune Transport Types • PIM Flooding Mechanism Message Types • PIM Designated Router Load-Balancing Hash Algorithms • PIM Flooding Mechanism Group Source Info Sub-TLV Types PIM-Hello Options Registration Procedure(s) First Come First Served (expire in 1 year); Specification Required for Permanent assignments Expert(s) Stig Venaas, Jeffrey (Zhaohui) Zhang Reference [RFC 7761][RFC 3973] Available Formats [IMG] CSV Value Length Name Reference 0 Reserved [RFC 3973] 1 2 Hold Time [RFC 7761] 2 4 LAN Prune Delay [RFC 3973] 3-16 - Reserved [RFC 7761] 17 16 Label Parameters (renew 8/01) [Dino_Farinacci] 18 - Deprecated 19 4 DR Priority (renew 8/01) [RFC 7761] 20 4 Generation ID [RFC 3973] 21 4 State-Refresh [RFC 3973] 22 0 Bidirectional Capable [RFC 5015] 23 1 VCI Capability (renew 8/01) [Dino_Farinacci] 24 variable Address List [RFC 7761] 25 variable Neighbor List TLV (renew 5/07) [Alex_Zinin] 26 0 Join Attribute [RFC 5384] 27 variable PIM-over-TCP-Capable [RFC 6559] 28 variable PIM-over-SCTP-Capable [RFC 6559] 29 variable Pop-Count [RFC 6807] 30 0 PIM MT-ID [RFC 6420] 31 8 Interface ID [RFC 6395] 32 0 PIM ECMP Redirect Hello Option [RFC 6754] 33 2 vPC Peer ID (renew 6/14) [Siddanagouda_Khot] 34 4 DR Load-Balancing Capability (DRLB-Cap) [RFC 8775] 35 variable DR Load-Balancing List (DRLB-List) [RFC 8775] 36 0 Hierarchical Join/Prune Attribute [RFC 7887] 37 variable DR Address Option [draft-ietf-pim-dr-improvement-10] 38 variable BDR Address Option [draft-ietf-pim-dr-improvement-10] 39 4 BFD Discriminator Option [RFC 9186] 40 0 Packed Assert Capability [RFC 9466] 41 0 GSI TLV support [RFC-ietf-pim-pfm-forwarding-enhancements-08] 42 0 PFM Optimization [RFC-ietf-pim-pfm-forwarding-enhancements-08] 43-65000 - Unassigned 65001-65535 - Reserved (Private Use) PIM Join Attribute Types Registration Procedure(s) IETF Review Reference [RFC 5384] Available Formats [IMG] CSV Value Name Reference 0 RPF Vector TLV [RFC 5496] 1 MVPN Join Attribute [RFC 6513] 2 MT-ID Join Attribute [RFC 6420] 3 Pop-Count [RFC 6807] 4 Explicit RPF Vector [RFC 7891] 5 Transport Attribute [RFC 8059] 6 Receiver RLOC Attribute [RFC 8059] 7-63 Unassigned PIM Address Family Registration Procedure(s) IESG Approval Reference [RFC 3973][RFC 7761] Available Formats [IMG] CSV Value Description Reference 0-127 Same meaning as Address Family Numbers. See http://www.iana.org/assignments/address-family-numbers 128-250 Unassigned 251-255 Reserved for Private Use [RFC 3973] PIM Address Encoding Types Registration Procedure(s) IETF Review Reference [RFC 5384][RFC 7761][RFC 7887] Available Formats [IMG] CSV Value Description Reference 0 native encoding for the address family [RFC 7761] 1 native encoding for the address family, but with one or more PIM Join Attributes present [RFC 5384]; [RFC Errata 1597] 2-255 Unassigned PIM Message Types Registration Procedure(s) IETF Review Reference [RFC 9436] Available Formats [IMG] CSV Type Name Flag Bits Reference 0 Hello 0-7: Unassigned [RFC 3973]; [RFC 7761] 1 Register 0-7: Unassigned [RFC 7761] 2 Register Stop 0: Packing Capability [RFC 9465] 1-7: Unassigned [RFC 7761] 3 Join/Prune 0-7: Unassigned [RFC 3973]; [RFC 7761] 4 Bootstrap 0-6: Unassigned [RFC 5059]; [RFC 7761] 7: No-Forward [RFC 5059] 5 Assert 0: Packed [RFC 9466] 1: Aggregated [RFC 9466] 2-7: Unassigned [RFC 3973]; [RFC 7761] 6 Graft 0-7: Unassigned [RFC 3973] 7 Graft-Ack 0-7: Unassigned [RFC 3973] 8 Candidate RP Advertisement 0-7: Unassigned [RFC 7761] 9 State Refresh 0-7: Unassigned [RFC 3973] 10 DF Election 0-3: Unassigned [RFC 5015] 4-7: Subtype [RFC 5015] 11 ECMP Redirect 0-7: Unassigned [RFC 6754] 12 PIM Flooding Mechanism 0-6: Unassigned [RFC 8364] 7: No-Forward [RFC 8364] 13.0 PIM Packed Null-Register 0-3: Unassigned [RFC 9465] 13.1 PIM Packed Register-Stop 0-3: Unassigned [RFC 9465] 13.2-15.14 Unassigned 0-3: Unassigned 15.15 Reserved 0-3: Reserved [RFC 9436] PORT Message Types Registration Procedure(s) RFC Required Reference [RFC 6559] Available Formats [IMG] CSV Type Name Reference 0 Reserved [RFC 6559] 1 Join/Prune [RFC 6559] 2 Keep-alive [RFC 6559] 3-65531 Unassigned 65532-65535 Experimental [RFC 6559] PORT Option Types Registration Procedure(s) RFC Required Reference [RFC 6559] Available Formats [IMG] CSV Type Name Reference 0 Reserved [RFC 6559] 1 PIM IPv4 Join/Prune [RFC 6559] 2 PIM IPv6 Join/Prune [RFC 6559] 3-32763 Unassigned Critical Options 32764-32767 Experimental [RFC 6559] 32768-65531 Unassigned Non-Critical Options 65532-65535 Experimental [RFC 6559] PIM Join/Prune Transport Types Registration Procedure(s) IETF Review Reference [RFC 8059] Available Formats [IMG] CSV Value Description Reference 0 multicast [RFC 8059] 1 unicast [RFC 8059] 2-255 Unassigned PIM Flooding Mechanism Message Types Registration Procedure(s) IETF Review Reference [RFC 8364] Available Formats [IMG] CSV Type Name Reference 0 Reserved [RFC 8364] 1 Source Group Holdtime [RFC 8364] 2 Group Source Info [RFC-ietf-pim-pfm-forwarding-enhancements-08] 3-32767 Unassigned PIM Designated Router Load-Balancing Hash Algorithms Registration Procedure(s) IETF Review Reference [RFC 8775] Available Formats [IMG] CSV Type Name Reference 0 Modulo [RFC 8775] 1-255 Unassigned PIM Flooding Mechanism Group Source Info Sub-TLV Types Registration Procedure(s) IETF Review Reference [RFC-ietf-pim-pfm-forwarding-enhancements-08] Available Formats [IMG] CSV Type Name Reference 0-32767 Unassigned Contact Information ID Name Contact URI Last Updated [Alex_Zinin] Alex Zinin mailto:zinin&psg.com 2006-05-01 [Dino_Farinacci] Dino Farinacci mailto:dino&procket.com 2000-08 [Siddanagouda_Khot] Siddanagouda Khot mailto:sikhot&cisco.com 2013-06-06 Licensing Terms