Security Hub CSPM
| Version | 7.1.4 (View all) |
| Managed integration release status |
|
| Subscription level What's this? |
Basic |
| Ingestion method(s) | API, AWS CloudWatch, AWS S3 |
| Minimum Kibana version(s) | 9.4.0 |
You can use this integration as an Elastic Managed integration on Elastic Cloud Hosted deployments running this version or later.
The AWS Security Hub CSPM integration collects and parses data from AWS Security Hub REST APIs.
Extra AWS charges on API requests will be generated by this integration. Check API Requests for more details.
Agentless integrations allow you to collect data without having to manage Elastic Agent in your cloud. They make manual agent deployment unnecessary, so you can focus on your data instead of the agent that collects it. For more information, refer to Agentless integrations and the Agentless integrations FAQ. Agentless deployments are only supported in Elastic Serverless and Elastic Cloud environments. This functionality is in beta and is subject to change. Beta features are not subject to the support SLA of official GA features.
- The minimum compatible version of this module is
Elastic Agent 8.4.0. - This module is tested against
AWS Security Hub API version 1.0.
- Login to https://console.aws.amazon.com/.
- Go to https://console.aws.amazon.com/iam/ to access the IAM console.
- On the navigation menu, choose Users.
- Choose your IAM user name.
- Select Create access key from the Security Credentials tab.
- To see the new access key, choose Show.
- For the current integration package, it is recommended to have interval in hours.
- For the current integration package, it is compulsory to add Secret Access Key and Access Key ID.
- Findings Full Posture data stream request all the historical findings every 24 hours.
This is the securityhub_findings data stream.
Example
{
"@timestamp": "2018-08-31T00:15:09.000Z",
"agent": {
"ephemeral_id": "b333f80a-aa3c-4180-bedc-b55bef909b01",
"id": "76aef659-3329-4b2e-a6c1-36bb8389faac",
"name": "elastic-agent-79144",
"type": "filebeat",
"version": "8.19.4"
},
"aws": {
"securityhub_findings": {
"action": {
"port_probe": {
"blocked": false,
"details": [
{
"local": {
"ip": {
"address_v4": "1.128.0.0"
},
"port": {
"name": "HTTP",
"number": 80
}
},
"remote_ip": {
"city": {
"name": "Example City"
},
"country": {
"name": "Example Country"
},
"geolocation": {
"latitude": 0,
"longitude": 0
},
"organization": {
"asn": "64496",
"asn_organization": "ExampleASO",
"internet_provider": "ExampleOrg",
"internet_service_provider": "ExampleISP"
}
}
}
]
}
},
"aws_account_id": "111111111111",
"company": {
"name": "AWS"
},
"compliance": {
"related_requirements": [
"Req1",
"Req2"
],
"status": "PASSED",
"status_reasons": [
{
"description": "CloudWatch alarms do not exist in the account",
"reason_code": "CLOUDWATCH_ALARMS_NOT_PRESENT"
}
]
},
"confidence": 42,
"criticality": 99,
"description": "The version of openssl found on instance i-abcd1234 is known to contain a vulnerability.",
"first_observed_at": "2017-03-22T13:22:13.933Z",
"generator": {
"id": "acme-vuln-9ab348"
},
"last_observed_at": "2017-03-23T13:22:13.933Z",
"malware": [
{
"name": "Stringler",
"path": "/usr/sbin/stringler",
"state": "OBSERVED",
"type": "COIN_MINER"
}
],
"network": {
"open_port_range": {
"begin": 443,
"end": 443
}
},
"network_path": [
{
"component": {
"id": "abc-01a234bc56d8901ee",
"type": "AWS::EC2::InternetGateway"
},
"egress": {
"destination": {
"address": [
"1.128.0.0/24"
],
"port_ranges": [
{
"begin": 443,
"end": 443
}
]
},
"protocol": "TCP",
"source": {
"address": [
"175.16.199.1/24"
]
}
},
"ingress": {
"destination": {
"address": [
"175.16.199.1/24"
],
"port_ranges": [
{
"begin": 443,
"end": 443
}
]
},
"protocol": "TCP",
"source": {
"address": [
"175.16.199.1/24"
]
}
}
}
],
"note": {
"text": "Don't forget to check under the mat.",
"updated_at": "2018-08-31T00:15:09.000Z",
"updated_by": "jsmith"
},
"patch_summary": {
"failed": {
"count": 0
},
"id": "pb-123456789098",
"installed": {
"count": 100,
"other": {
"count": 1023
},
"pending_reboot": 0,
"rejected": {
"count": 0
}
},
"missing": {
"count": 100
},
"operation": {
"end_time": "2018-09-27T23:39:31.000Z",
"start_time": "2018-09-27T23:37:31.000Z",
"type": "Install"
},
"reboot_option": "RebootIfNeeded"
},
"product": {
"arn": "arn:aws:securityhub:us-east-1:111111111111:product/111111111111/default",
"fields": {
"Service_Name": "cloudtrail.amazonaws.com",
"aws/inspector/AssessmentTargetName": "My prod env",
"aws/inspector/AssessmentTemplateName": "My daily CVE assessment",
"aws/inspector/RulesPackageName": "Common Vulnerabilities and Exposures",
"generico/secure-pro/Count": "6"
},
"name": "Security Hub"
},
"provider_fields": {
"confidence": 42,
"criticality": 99,
"related_findings": [
{
"id": "123e4567-e89b-12d3-a456-426655440000",
"product": {
"arn": "arn:aws:securityhub:us-west-2::product/aws/guardduty"
}
}
],
"severity": {
"label": "MEDIUM",
"original": "MEDIUM"
},
"types": [
"Software and Configuration Checks/Vulnerabilities/CVE"
]
},
"record_state": "ACTIVE",
"region": "us-east-1",
"related_findings": [
{
"id": "123e4567-e89b-12d3-a456-426655440000",
"product": {
"arn": "arn:aws:securityhub:us-west-2::product/aws/guardduty"
}
},
{
"id": "AcmeNerfHerder-111111111111-x189dx7824",
"product": {
"arn": "arn:aws:securityhub:us-west-2::product/aws/guardduty"
}
}
],
"remediation": {
"recommendation": {
"text": "Run sudo yum update and cross your fingers and toes.",
"url": "http://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html"
}
},
"resources": [
{
"Details": {
"IamInstanceProfileArn": "arn:aws:iam::123456789012:role/IamInstanceProfileArn",
"ImageId": "ami-79fd7eee",
"IpV4Addresses": [
"175.16.199.1"
],
"IpV6Addresses": [
"2a02:cf40::"
],
"KeyName": "testkey",
"LaunchedAt": "2018-09-29T01:25:54Z",
"MetadataOptions": {
"HttpEndpoint": "enabled",
"HttpProtocolIpv6": "enabled",
"HttpPutResponseHopLimit": 1,
"HttpTokens": "optional",
"InstanceMetadataTags": "disabled"
},
"NetworkInterfaces": [
{
"NetworkInterfaceId": "eni-e5aa89a3"
}
],
"SubnetId": "PublicSubnet",
"Type": "i3.xlarge",
"VirtualizationType": "hvm",
"VpcId": "TestVPCIpv6"
},
"Id": "i-cafebabe",
"Partition": "aws",
"Region": "us-west-2",
"Tags": {
"billingCode": "Lotus-1-2-3",
"needsPatching": "true"
},
"Type": "AwsEc2Instance"
}
],
"sample": true,
"schema": {
"version": "2018-10-08"
},
"severity": {
"label": "CRITICAL",
"original": "8.3"
},
"source_url": "http://threatintelweekly.org/backdoors/8888",
"threat_intel_indicators": [
{
"category": "BACKDOOR",
"source": "Threat Intel Weekly",
"source_url": "http://threatintelweekly.org/backdoors/8888",
"value": "175.16.199.1"
}
],
"title": "EC2.20 Both VPN tunnels for an AWS Site-to-Site VPN connection should be up",
"types": [
"Software and Configuration Checks/Vulnerabilities/CVE"
],
"updated_at": "2018-08-31T00:15:09.000Z",
"user_defined_fields": {
"comeBackToLater": "Check this again on Monday",
"reviewedByCio": "true"
},
"verification_state": "UNKNOWN",
"vulnerabilities": [
{
"cvss": [
{
"base_score": 4.7,
"base_vector": "AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N",
"version": "V3"
},
{
"base_score": 4.7,
"base_vector": "AV:L/AC:M/Au:N/C:C/I:N/A:N",
"version": "V2"
}
],
"related_vulnerabilities": [
"CVE-2020-12345"
],
"vendor": {
"created_at": "2020-01-16T00:01:43.000Z",
"severity": "Medium",
"updated_at": "2020-01-16T00:01:43.000Z",
"url": "https://alas.aws.amazon.com/ALAS-2020-1337.html"
},
"vulnerable_packages": [
{
"architecture": "x86_64",
"epoch": "1",
"name": "openssl",
"release": "16.amzn2.0.3",
"version": "1.0.2k"
}
]
}
],
"workflow": {
"state": "NEW",
"status": "NEW"
}
}
},
"cloud": {
"account": {
"id": "111111111111"
},
"instance": {
"id": "i-cafebabe",
"name": "i-cafebabe"
},
"provider": "aws",
"region": "us-east-1"
},
"data_stream": {
"dataset": "aws.securityhub_findings",
"namespace": "43694",
"type": "logs"
},
"destination": {
"domain": "example2.com",
"ip": [
"1.128.0.0",
"2a02:cf40::"
],
"port": 80
},
"ecs": {
"version": "8.11.0"
},
"elastic_agent": {
"id": "76aef659-3329-4b2e-a6c1-36bb8389faac",
"snapshot": false,
"version": "8.19.4"
},
"event": {
"action": "port_probe",
"agent_id_status": "verified",
"category": [
"configuration"
],
"created": "2025-12-09T05:40:33.772Z",
"dataset": "aws.securityhub_findings",
"id": "us-west-2/111111111111/98aebb2207407c87f51e89943f12b1ef",
"ingested": "2025-12-09T05:40:36Z",
"kind": "state",
"original": "{\"Action\":{\"ActionType\":\"PORT_PROBE\",\"PortProbeAction\":{\"Blocked\":false,\"PortProbeDetails\":[{\"LocalIpDetails\":{\"IpAddressV4\":\"1.128.0.0\"},\"LocalPortDetails\":{\"Port\":80,\"PortName\":\"HTTP\"},\"RemoteIpDetails\":{\"City\":{\"CityName\":\"Example City\"},\"Country\":{\"CountryName\":\"Example Country\"},\"GeoLocation\":{\"Lat\":0,\"Lon\":0},\"Organization\":{\"Asn\":64496,\"AsnOrg\":\"ExampleASO\",\"Isp\":\"ExampleISP\",\"Org\":\"ExampleOrg\"}}}]}},\"AwsAccountId\":\"111111111111\",\"CompanyName\":\"AWS\",\"Compliance\":{\"RelatedRequirements\":[\"Req1\",\"Req2\"],\"Status\":\"PASSED\",\"StatusReasons\":[{\"Description\":\"CloudWatch alarms do not exist in the account\",\"ReasonCode\":\"CLOUDWATCH_ALARMS_NOT_PRESENT\"}]},\"Confidence\":42,\"CreatedAt\":\"2017-03-22T13:22:13.933Z\",\"Criticality\":99,\"Description\":\"The version of openssl found on instance i-abcd1234 is known to contain a vulnerability.\",\"FindingProviderFields\":{\"Confidence\":42,\"Criticality\":99,\"RelatedFindings\":[{\"Id\":\"123e4567-e89b-12d3-a456-426655440000\",\"ProductArn\":\"arn:aws:securityhub:us-west-2::product/aws/guardduty\"}],\"Severity\":{\"Label\":\"MEDIUM\",\"Original\":\"MEDIUM\"},\"Types\":[\"Software and Configuration Checks/Vulnerabilities/CVE\"]},\"FirstObservedAt\":\"2017-03-22T13:22:13.933Z\",\"GeneratorId\":\"acme-vuln-9ab348\",\"Id\":\"us-west-2/111111111111/98aebb2207407c87f51e89943f12b1ef\",\"LastObservedAt\":\"2017-03-23T13:22:13.933Z\",\"Malware\":[{\"Name\":\"Stringler\",\"Path\":\"/usr/sbin/stringler\",\"State\":\"OBSERVED\",\"Type\":\"COIN_MINER\"}],\"Network\":{\"DestinationDomain\":\"example2.com\",\"DestinationIpV4\":\"1.128.0.0\",\"DestinationIpV6\":\"2a02:cf40::\",\"DestinationPort\":\"80\",\"Direction\":\"IN\",\"OpenPortRange\":{\"Begin\":443,\"End\":443},\"Protocol\":\"TCP\",\"SourceDomain\":\"example1.com\",\"SourceIpV4\":\"1.128.0.0\",\"SourceIpV6\":\"2a02:cf40::\",\"SourceMac\":\"00:0d:83:b1:c0:8e\",\"SourcePort\":\"42\"},\"NetworkPath\":[{\"ComponentId\":\"abc-01a234bc56d8901ee\",\"ComponentType\":\"AWS::EC2::InternetGateway\",\"Egress\":{\"Destination\":{\"Address\":[\"1.128.0.0/24\"],\"PortRanges\":[{\"Begin\":443,\"End\":443}]},\"Protocol\":\"TCP\",\"Source\":{\"Address\":[\"175.16.199.1/24\"]}},\"Ingress\":{\"Destination\":{\"Address\":[\"175.16.199.1/24\"],\"PortRanges\":[{\"Begin\":443,\"End\":443}]},\"Protocol\":\"TCP\",\"Source\":{\"Address\":[\"175.16.199.1/24\"]}}}],\"Note\":{\"Text\":\"Don't forget to check under the mat.\",\"UpdatedAt\":\"2018-08-31T00:15:09Z\",\"UpdatedBy\":\"jsmith\"},\"PatchSummary\":{\"FailedCount\":\"0\",\"Id\":\"pb-123456789098\",\"InstalledCount\":\"100\",\"InstalledOtherCount\":\"1023\",\"InstalledPendingReboot\":\"0\",\"InstalledRejectedCount\":\"0\",\"MissingCount\":\"100\",\"Operation\":\"Install\",\"OperationEndTime\":\"2018-09-27T23:39:31Z\",\"OperationStartTime\":\"2018-09-27T23:37:31Z\",\"RebootOption\":\"RebootIfNeeded\"},\"Process\":{\"LaunchedAt\":\"2018-09-27T22:37:31Z\",\"Name\":\"syslogd\",\"ParentPid\":56789,\"Path\":\"/usr/sbin/syslogd\",\"Pid\":12345,\"TerminatedAt\":\"2018-09-27T23:37:31Z\"},\"ProductArn\":\"arn:aws:securityhub:us-east-1:111111111111:product/111111111111/default\",\"ProductFields\":{\"Service_Name\":\"cloudtrail.amazonaws.com\",\"aws/inspector/AssessmentTargetName\":\"My prod env\",\"aws/inspector/AssessmentTemplateName\":\"My daily CVE assessment\",\"aws/inspector/RulesPackageName\":\"Common Vulnerabilities and Exposures\",\"generico/secure-pro/Count\":\"6\"},\"ProductName\":\"Security Hub\",\"RecordState\":\"ACTIVE\",\"Region\":\"us-east-1\",\"RelatedFindings\":[{\"Id\":\"123e4567-e89b-12d3-a456-426655440000\",\"ProductArn\":\"arn:aws:securityhub:us-west-2::product/aws/guardduty\"},{\"Id\":\"AcmeNerfHerder-111111111111-x189dx7824\",\"ProductArn\":\"arn:aws:securityhub:us-west-2::product/aws/guardduty\"}],\"Remediation\":{\"Recommendation\":{\"Text\":\"Run sudo yum update and cross your fingers and toes.\",\"Url\":\"http://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html\"}},\"Resources\":[{\"Details\":{\"IamInstanceProfileArn\":\"arn:aws:iam::123456789012:role/IamInstanceProfileArn\",\"ImageId\":\"ami-79fd7eee\",\"IpV4Addresses\":[\"175.16.199.1\"],\"IpV6Addresses\":[\"2a02:cf40::\"],\"KeyName\":\"testkey\",\"LaunchedAt\":\"2018-09-29T01:25:54Z\",\"MetadataOptions\":{\"HttpEndpoint\":\"enabled\",\"HttpProtocolIpv6\":\"enabled\",\"HttpPutResponseHopLimit\":1,\"HttpTokens\":\"optional\",\"InstanceMetadataTags\":\"disabled\"},\"NetworkInterfaces\":[{\"NetworkInterfaceId\":\"eni-e5aa89a3\"}],\"SubnetId\":\"PublicSubnet\",\"Type\":\"i3.xlarge\",\"VirtualizationType\":\"hvm\",\"VpcId\":\"TestVPCIpv6\"},\"Id\":\"i-cafebabe\",\"Partition\":\"aws\",\"Region\":\"us-west-2\",\"Tags\":{\"billingCode\":\"Lotus-1-2-3\",\"needsPatching\":\"true\"},\"Type\":\"AwsEc2Instance\"}],\"Sample\":true,\"SchemaVersion\":\"2018-10-08\",\"Severity\":{\"Label\":\"CRITICAL\",\"Original\":\"8.3\"},\"SourceUrl\":\"http://threatintelweekly.org/backdoors/8888\",\"ThreatIntelIndicators\":[{\"Category\":\"BACKDOOR\",\"LastObservedAt\":\"2018-09-27T23:37:31Z\",\"Source\":\"Threat Intel Weekly\",\"SourceUrl\":\"http://threatintelweekly.org/backdoors/8888\",\"Type\":\"IPV4_ADDRESS\",\"Value\":\"175.16.199.1\"}],\"Threats\":[{\"FilePaths\":[{\"FileName\":\"b.txt\",\"FilePath\":\"/tmp/b.txt\",\"Hash\":\"sha256\",\"ResourceId\":\"arn:aws:ec2:us-west-2:123456789012:volume/vol-032f3bdd89aee112f\"}],\"ItemCount\":3,\"Name\":\"Iot.linux.mirai.vwisi\",\"Severity\":\"HIGH\"}],\"Title\":\"EC2.20 Both VPN tunnels for an AWS Site-to-Site VPN connection should be up\",\"Types\":[\"Software and Configuration Checks/Vulnerabilities/CVE\"],\"UpdatedAt\":\"2018-08-31T00:15:09Z\",\"UserDefinedFields\":{\"comeBackToLater\":\"Check this again on Monday\",\"reviewedByCio\":\"true\"},\"VerificationState\":\"UNKNOWN\",\"Vulnerabilities\":[{\"Cvss\":[{\"BaseScore\":4.7,\"BaseVector\":\"AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N\",\"Version\":\"V3\"},{\"BaseScore\":4.7,\"BaseVector\":\"AV:L/AC:M/Au:N/C:C/I:N/A:N\",\"Version\":\"V2\"}],\"Id\":\"CVE-2020-12345\",\"ReferenceUrls\":[\"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12418\",\"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17563\"],\"RelatedVulnerabilities\":[\"CVE-2020-12345\"],\"Vendor\":{\"Name\":\"Alas\",\"Url\":\"https://alas.aws.amazon.com/ALAS-2020-1337.html\",\"VendorCreatedAt\":\"2020-01-16T00:01:43Z\",\"VendorSeverity\":\"Medium\",\"VendorUpdatedAt\":\"2020-01-16T00:01:43Z\"},\"VulnerablePackages\":[{\"Architecture\":\"x86_64\",\"Epoch\":\"1\",\"Name\":\"openssl\",\"Release\":\"16.amzn2.0.3\",\"Version\":\"1.0.2k\"}]}],\"Workflow\":{\"Status\":\"NEW\"},\"WorkflowState\":\"NEW\"}",
"outcome": "success",
"type": [
"info"
]
},
"host": {
"id": "i-cafebabe"
},
"input": {
"type": "httpjson"
},
"network": {
"direction": "inbound",
"protocol": "tcp"
},
"observer": {
"vendor": "AWS Security Hub CSPM"
},
"organization": {
"name": "AWS"
},
"process": {
"end": "2018-09-27T23:37:31.000Z",
"executable": "/usr/sbin/syslogd",
"name": "syslogd",
"parent": {
"pid": 56789
},
"pid": 12345,
"start": "2018-09-27T22:37:31.000Z"
},
"related": {
"ip": [
"1.128.0.0",
"2a02:cf40::"
]
},
"resource": {
"id": "i-cafebabe",
"name": "i-cafebabe",
"type": "AwsEc2Instance"
},
"result": {
"evaluation": "passed"
},
"rule": {
"description": "The version of openssl found on instance i-abcd1234 is known to contain a vulnerability.",
"id": "acme-vuln-9ab348",
"name": "EC2.20 Both VPN tunnels for an AWS Site-to-Site VPN connection should be up",
"reference": "http://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html",
"remediation": "Run sudo yum update and cross your fingers and toes.\r\nhttp://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html",
"ruleset": [
"Req1",
"Req2"
]
},
"source": {
"domain": "example1.com",
"ip": [
"1.128.0.0",
"2a02:cf40::"
],
"mac": "00-0D-83-B1-C0-8E",
"port": 42
},
"tags": [
"preserve_original_event",
"forwarded",
"aws_securityhub_findings"
],
"threat": {
"indicator": {
"last_seen": "2018-09-27T23:37:31.000Z",
"type": "ipv4-addr"
}
},
"url": {
"domain": "threatintelweekly.org",
"full": "http://threatintelweekly.org/backdoors/8888",
"original": "http://threatintelweekly.org/backdoors/8888",
"path": "/backdoors/8888",
"scheme": "http"
},
"vulnerability": {
"id": "CVE-2020-12345",
"reference": [
"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12418",
"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17563"
],
"scanner": {
"vendor": "Alas"
},
"score": {
"base": 4.7,
"version": "V2"
}
}
}
ECS Field Reference
Please refer to the following document for detailed information on ECS fields.
Exported fields
| Field | Description | Type |
|---|---|---|
| @timestamp | Date/time when the event originated. This is the date/time extracted from the event, typically representing when the event was generated by the source. If the event source has no original timestamp, this value is typically populated by the first time the event was received by the pipeline. Required field for all events. | date |
| aws.securityhub_findings.action.aws_api_call.affected_resources | Identifies the resources that were affected by the API call. | flattened |
| aws.securityhub_findings.action.aws_api_call.api | The name of the API method that was issued. | keyword |
| aws.securityhub_findings.action.aws_api_call.caller.type | Indicates whether the API call originated from a remote IP address(remoteip) or from a DNS domain(domain). | keyword |
| aws.securityhub_findings.action.aws_api_call.domain_details.domain | The name of the DNS domain that issued the API call. | keyword |
| aws.securityhub_findings.action.aws_api_call.first_seen | An ISO8601-formatted timestamp that indicates when the API call was first observed. | date |
| aws.securityhub_findings.action.aws_api_call.last_seen | An ISO8601-formatted timestamp that indicates when the API call was most recently observed. | date |
| aws.securityhub_findings.action.aws_api_call.remote_ip.city.name | The name of the city. | keyword |
| aws.securityhub_findings.action.aws_api_call.remote_ip.country.code | The 2-letter ISO 3166 country code for the country. | keyword |
| aws.securityhub_findings.action.aws_api_call.remote_ip.country.name | The name of the country. | keyword |
| aws.securityhub_findings.action.aws_api_call.remote_ip.geolocation.latitude | The longitude of the location. | double |
| aws.securityhub_findings.action.aws_api_call.remote_ip.geolocation.longitude | The latitude of the location. | double |
| aws.securityhub_findings.action.aws_api_call.remote_ip.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings.action.aws_api_call.remote_ip.organization.asn | The Autonomous System Number(ASN) of the internet provider. | keyword |
| aws.securityhub_findings.action.aws_api_call.remote_ip.organization.asn_organization | The name of the organization that registered the ASN. | keyword |
| aws.securityhub_findings.action.aws_api_call.remote_ip.organization.internet_provider | The ISP information for the internet provider. | keyword |
| aws.securityhub_findings.action.aws_api_call.remote_ip.organization.internet_service_provider | The name of the internet provider. | keyword |
| aws.securityhub_findings.action.aws_api_call.service.name | The name of the Amazon Web Services service that the API method belongs to. | keyword |
| aws.securityhub_findings.action.dns_request.blocked | Indicates whether the DNS request was blocked. | boolean |
| aws.securityhub_findings.action.dns_request.domain | The DNS domain that is associated with the DNS request. | keyword |
| aws.securityhub_findings.action.dns_request.protocol | The protocol that was used for the DNS request. | keyword |
| aws.securityhub_findings.action.network_connection.blocked | Indicates whether the network connection attempt was blocked. | boolean |
| aws.securityhub_findings.action.network_connection.direction | The direction of the network connection request(IN or OUT). | keyword |
| aws.securityhub_findings.action.network_connection.local.port.name | The port name of the local connection. | keyword |
| aws.securityhub_findings.action.network_connection.local.port.number | The number of the port. | long |
| aws.securityhub_findings.action.network_connection.protocol | The protocol used to make the network connection request. | keyword |
| aws.securityhub_findings.action.network_connection.remote.port.name | The port name of the remote connection. | keyword |
| aws.securityhub_findings.action.network_connection.remote.port.number | The number of the port. | long |
| aws.securityhub_findings.action.network_connection.remote_ip.city.name | The name of the city. | keyword |
| aws.securityhub_findings.action.network_connection.remote_ip.country.code | The 2-letter ISO 3166 country code for the country. | keyword |
| aws.securityhub_findings.action.network_connection.remote_ip.country.name | The name of the country. | keyword |
| aws.securityhub_findings.action.network_connection.remote_ip.geolocation.latitude | The longitude of the location. | double |
| aws.securityhub_findings.action.network_connection.remote_ip.geolocation.longitude | The latitude of the location. | double |
| aws.securityhub_findings.action.network_connection.remote_ip.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings.action.network_connection.remote_ip.organization.asn | The Autonomous System Number(ASN) of the internet provider. | keyword |
| aws.securityhub_findings.action.network_connection.remote_ip.organization.asn_organization | The name of the organization that registered the ASN. | keyword |
| aws.securityhub_findings.action.network_connection.remote_ip.organization.internet_provider | The ISP information for the internet provider. | keyword |
| aws.securityhub_findings.action.network_connection.remote_ip.organization.internet_service_provider | The name of the internet provider. | keyword |
| aws.securityhub_findings.action.port_probe.blocked | Indicates whether the port probe was blocked. | boolean |
| aws.securityhub_findings.action.port_probe.details.local.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings.action.port_probe.details.local.port.name | The port name of the local connection. | keyword |
| aws.securityhub_findings.action.port_probe.details.local.port.number | The number of the port. | long |
| aws.securityhub_findings.action.port_probe.details.remote_ip.city.name | The name of the city. | keyword |
| aws.securityhub_findings.action.port_probe.details.remote_ip.country.code | The 2-letter ISO 3166 country code for the country. | keyword |
| aws.securityhub_findings.action.port_probe.details.remote_ip.country.name | The name of the country. | keyword |
| aws.securityhub_findings.action.port_probe.details.remote_ip.geolocation.latitude | The longitude of the location. | double |
| aws.securityhub_findings.action.port_probe.details.remote_ip.geolocation.longitude | The latitude of the location. | double |
| aws.securityhub_findings.action.port_probe.details.remote_ip.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings.action.port_probe.details.remote_ip.organization.asn | The Autonomous System Number(ASN) of the internet provider. | keyword |
| aws.securityhub_findings.action.port_probe.details.remote_ip.organization.asn_organization | The name of the organization that registered the ASN. | keyword |
| aws.securityhub_findings.action.port_probe.details.remote_ip.organization.internet_provider | The ISP information for the internet provider. | keyword |
| aws.securityhub_findings.action.port_probe.details.remote_ip.organization.internet_service_provider | The name of the internet provider. | keyword |
| aws.securityhub_findings.action.type | The type of action that was detected. | keyword |
| aws.securityhub_findings.aws_account_id | The Amazon Web Services account ID that a finding is generated in. | keyword |
| aws.securityhub_findings.company.name | The name of the company for the product that generated the finding. | keyword |
| aws.securityhub_findings.compliance.related_requirements | For a control, the industry or regulatory framework requirements that are related to the control. | keyword |
| aws.securityhub_findings.compliance.security_control_id | Unique identifier of a control across standards. | keyword |
| aws.securityhub_findings.compliance.status | The result of a standards check. | keyword |
| aws.securityhub_findings.compliance.status_reasons.description | The corresponding description for the status reason code. | keyword |
| aws.securityhub_findings.compliance.status_reasons.reason_code | A code that represents a reason for the control status. | keyword |
| aws.securityhub_findings.confidence | A finding's confidence. Confidence is defined as the likelihood that a finding accurately identifies the behavior or issue that it was intended to identify. | long |
| aws.securityhub_findings.created_at | Indicates when the security-findings provider created the potential security issue that a finding captured. | date |
| aws.securityhub_findings.criticality | The level of importance assigned to the resources associated with the finding. | long |
| aws.securityhub_findings.description | A finding's description. | keyword |
| aws.securityhub_findings.first_observed_at | Indicates when the security-findings provider first observed the potential security issue that a finding captured. | date |
| aws.securityhub_findings.generator.id | The identifier for the solution-specific component(a discrete unit of logic) that generated a finding. In various security-findings providers' solutions, this generator can be called a rule, a check, a detector, a plugin, etc. | keyword |
| aws.securityhub_findings.id | The security findings provider-specific identifier for a finding. | keyword |
| aws.securityhub_findings.last_observed_at | Indicates when the security-findings provider most recently observed the potential security issue that a finding captured. | date |
| aws.securityhub_findings.malware.name | The name of the malware that was observed. | keyword |
| aws.securityhub_findings.malware.path | The file system path of the malware that was observed. | keyword |
| aws.securityhub_findings.malware.state | The state of the malware that was observed. | keyword |
| aws.securityhub_findings.malware.type | The type of the malware that was observed. | keyword |
| aws.securityhub_findings.network.destination.domain | The destination domain of network-related information about a finding. | keyword |
| aws.securityhub_findings.network.destination.ip.v4 | The destination IPv4 address of network-related information about a finding. | ip |
| aws.securityhub_findings.network.destination.ip.v6 | The destination IPv6 address of network-related information about a finding. | ip |
| aws.securityhub_findings.network.destination.port | The destination port of network-related information about a finding. | long |
| aws.securityhub_findings.network.direction | The direction of network traffic associated with a finding. | keyword |
| aws.securityhub_findings.network.open_port_range.begin | The first port in the port range. | long |
| aws.securityhub_findings.network.open_port_range.end | The last port in the port range. | long |
| aws.securityhub_findings.network.protocol | The protocol of network-related information about a finding. | keyword |
| aws.securityhub_findings.network.source.domain | The source domain of network-related information about a finding. | keyword |
| aws.securityhub_findings.network.source.ip.v4 | The source IPv4 address of network-related information about a finding. | ip |
| aws.securityhub_findings.network.source.ip.v6 | The source IPv6 address of network-related information about a finding. | ip |
| aws.securityhub_findings.network.source.mac | The source media access control(MAC) address of network-related information about a finding. | keyword |
| aws.securityhub_findings.network.source.port | The source port of network-related information about a finding. | long |
| aws.securityhub_findings.network_path.component.id | The identifier of a component in the network path. | keyword |
| aws.securityhub_findings.network_path.component.type | The type of component. | keyword |
| aws.securityhub_findings.network_path.egress.destination.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings.network_path.egress.destination.port_ranges.begin | The first port in the port range. | long |
| aws.securityhub_findings.network_path.egress.destination.port_ranges.end | The last port in the port range. | long |
| aws.securityhub_findings.network_path.egress.protocol | The protocol used for the component. | keyword |
| aws.securityhub_findings.network_path.egress.source.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings.network_path.egress.source.port_ranges.begin | The first port in the port range. | long |
| aws.securityhub_findings.network_path.egress.source.port_ranges.end | The last port in the port range. | long |
| aws.securityhub_findings.network_path.ingress.destination.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings.network_path.ingress.destination.port_ranges.begin | The first port in the port range. | long |
| aws.securityhub_findings.network_path.ingress.destination.port_ranges.end | The last port in the port range. | long |
| aws.securityhub_findings.network_path.ingress.protocol | The protocol used for the component. | keyword |
| aws.securityhub_findings.network_path.ingress.source.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings.network_path.ingress.source.port_ranges.begin | The first port in the port range. | long |
| aws.securityhub_findings.network_path.ingress.source.port_ranges.end | The last port in the port range. | long |
| aws.securityhub_findings.note.text | The text of a note. | keyword |
| aws.securityhub_findings.note.updated_at | The timestamp of when the note was updated. | date |
| aws.securityhub_findings.note.updated_by | The principal that created a note. | keyword |
| aws.securityhub_findings.patch_summary.failed.count | The number of patches from the compliance standard that failed to install. | long |
| aws.securityhub_findings.patch_summary.id | The identifier of the compliance standard that was used to determine the patch compliance status. | keyword |
| aws.securityhub_findings.patch_summary.installed.count | The number of patches from the compliance standard that were installed successfully. | long |
| aws.securityhub_findings.patch_summary.installed.other.count | The number of installed patches that are not part of the compliance standard. | long |
| aws.securityhub_findings.patch_summary.installed.pending_reboot | The number of patches that were applied, but that require the instance to be rebooted in order to be marked as installed. | long |
| aws.securityhub_findings.patch_summary.installed.rejected.count | The number of patches that are installed but are also on a list of patches that the customer rejected. | long |
| aws.securityhub_findings.patch_summary.missing.count | The number of patches that are part of the compliance standard but are not installed. The count includes patches that failed to install. | long |
| aws.securityhub_findings.patch_summary.operation.end_time | Indicates when the operation completed. | date |
| aws.securityhub_findings.patch_summary.operation.start_time | Indicates when the operation started. | date |
| aws.securityhub_findings.patch_summary.operation.type | The type of patch operation performed. For Patch Manager, the values are SCAN and INSTALL. | keyword |
| aws.securityhub_findings.patch_summary.reboot_option | The reboot option specified for the instance. | keyword |
| aws.securityhub_findings.process.launched_at | Indicates when the process was launched. | date |
| aws.securityhub_findings.process.name | The name of the process. | keyword |
| aws.securityhub_findings.process.parent.pid | The parent process ID. | long |
| aws.securityhub_findings.process.path | The path to the process executable. | keyword |
| aws.securityhub_findings.process.pid | The process ID. | long |
| aws.securityhub_findings.process.terminated_at | Indicates when the process was terminated. | date |
| aws.securityhub_findings.processed_at | Indicates when AWS Security Hub received a finding and begins to process it. | date |
| aws.securityhub_findings.product.arn | The ARN generated by Security Hub that uniquely identifies a product that generates findings. This can be the ARN for a third-party product that is integrated with Security Hub, or the ARN for a custom integration. | keyword |
| aws.securityhub_findings.product.fields | A data type where security-findings providers can include additional solution-specific details that aren't part of the defined AwsSecurityFinding format. | flattened |
| aws.securityhub_findings.product.name | The name of the product that generated the finding. | keyword |
| aws.securityhub_findings.provider_fields.confidence | A finding's confidence. Confidence is defined as the likelihood that a finding accurately identifies the behavior or issue that it was intended to identify. | long |
| aws.securityhub_findings.provider_fields.criticality | The level of importance assigned to the resources associated with the finding. | long |
| aws.securityhub_findings.provider_fields.related_findings.id | The product-generated identifier for a related finding. | keyword |
| aws.securityhub_findings.provider_fields.related_findings.product.arn | The ARN of the product that generated a related finding. | keyword |
| aws.securityhub_findings.provider_fields.severity.label | The severity label assigned to the finding by the finding provider. | keyword |
| aws.securityhub_findings.provider_fields.severity.normalized | The normalized severity of a finding provider. | keyword |
| aws.securityhub_findings.provider_fields.severity.original | The finding provider's original value for the severity. | keyword |
| aws.securityhub_findings.provider_fields.severity.product | The finding provider's product for the severity. | keyword |
| aws.securityhub_findings.provider_fields.types | One or more finding types in the format of namespace/category/classifier that classify a finding. | keyword |
| aws.securityhub_findings.record_state | The record state of a finding. | keyword |
| aws.securityhub_findings.region | The Region from which the finding was generated. | keyword |
| aws.securityhub_findings.related_findings.id | The product-generated identifier for a related finding. | keyword |
| aws.securityhub_findings.related_findings.product.arn | The ARN of the product that generated a related finding. | keyword |
| aws.securityhub_findings.remediation.recommendation.text | Describes the recommended steps to take to remediate an issue identified in a finding. | text |
| aws.securityhub_findings.remediation.recommendation.url | A URL to a page or site that contains information about how to remediate a finding. | keyword |
| aws.securityhub_findings.resources | A set of resource data types that describe the resources that the finding refers to. | flattened |
| aws.securityhub_findings.sample | Indicates whether the finding is a sample finding. | boolean |
| aws.securityhub_findings.schema.version | The schema version that a finding is formatted for. | keyword |
| aws.securityhub_findings.severity.label | The severity value of the finding. | keyword |
| aws.securityhub_findings.severity.normalized | The normalized severity of a finding. | keyword |
| aws.securityhub_findings.severity.original | The native severity from the finding product that generated the finding. | keyword |
| aws.securityhub_findings.severity.product | The native severity as defined by the Amazon Web Services service or integrated partner product that generated the finding. | keyword |
| aws.securityhub_findings.source_url | A URL that links to a page about the current finding in the security-findings provider's solution. | keyword |
| aws.securityhub_findings.threat_intel_indicators.category | The category of a threat intelligence indicator. | keyword |
| aws.securityhub_findings.threat_intel_indicators.last_observed_at | Indicates when the most recent instance of a threat intelligence indicator was observed. | date |
| aws.securityhub_findings.threat_intel_indicators.source | The source of the threat intelligence indicator. | keyword |
| aws.securityhub_findings.threat_intel_indicators.source_url | The URL to the page or site where you can get more information about the threat intelligence indicator. | keyword |
| aws.securityhub_findings.threat_intel_indicators.type | The type of threat intelligence indicator. | keyword |
| aws.securityhub_findings.threat_intel_indicators.value | The value of a threat intelligence indicator. | keyword |
| aws.securityhub_findings.title | A finding's title. | text |
| aws.securityhub_findings.types | One or more finding types in the format of namespace/category/classifier that classify a finding. | keyword |
| aws.securityhub_findings.updated_at | Indicates when the security-findings provider last updated the finding record. | date |
| aws.securityhub_findings.user_defined_fields | A list of name/value string pairs associated with the finding. These are custom, user-defined fields added to a finding. | flattened |
| aws.securityhub_findings.verification_state | Indicates the veracity of a finding. | keyword |
| aws.securityhub_findings.vulnerabilities.cvss.adjustments.metric | The metric to adjust. | keyword |
| aws.securityhub_findings.vulnerabilities.cvss.adjustments.reason | The reason for the adjustment. | keyword |
| aws.securityhub_findings.vulnerabilities.cvss.base_score | The base CVSS score. | double |
| aws.securityhub_findings.vulnerabilities.cvss.base_vector | The base scoring vector for the CVSS score. | keyword |
| aws.securityhub_findings.vulnerabilities.cvss.source | The origin of the original CVSS score and vector. | keyword |
| aws.securityhub_findings.vulnerabilities.cvss.version | The version of CVSS for the CVSS score. | keyword |
| aws.securityhub_findings.vulnerabilities.id | The identifier of the vulnerability. | keyword |
| aws.securityhub_findings.vulnerabilities.reference_urls | A list of URLs that provide additional information about the vulnerability. | keyword |
| aws.securityhub_findings.vulnerabilities.related_vulnerabilities | List of vulnerabilities that are related to this vulnerability. | keyword |
| aws.securityhub_findings.vulnerabilities.vendor.created_at | Indicates when the vulnerability advisory was created. | date |
| aws.securityhub_findings.vulnerabilities.vendor.name | The name of the vendor. | keyword |
| aws.securityhub_findings.vulnerabilities.vendor.severity | The severity that the vendor assigned to the vulnerability. | keyword |
| aws.securityhub_findings.vulnerabilities.vendor.updated_at | Indicates when the vulnerability advisory was last updated. | date |
| aws.securityhub_findings.vulnerabilities.vendor.url | The URL of the vulnerability advisory. | keyword |
| aws.securityhub_findings.vulnerabilities.vulnerable_packages.architecture | The architecture used for the software package. | keyword |
| aws.securityhub_findings.vulnerabilities.vulnerable_packages.epoch | The epoch of the software package. | keyword |
| aws.securityhub_findings.vulnerabilities.vulnerable_packages.file_path | The file system path to the package manager inventory file. | keyword |
| aws.securityhub_findings.vulnerabilities.vulnerable_packages.name | The name of the software package. | keyword |
| aws.securityhub_findings.vulnerabilities.vulnerable_packages.package_manager | The source of the package. | keyword |
| aws.securityhub_findings.vulnerabilities.vulnerable_packages.release | The release of the software package. | keyword |
| aws.securityhub_findings.vulnerabilities.vulnerable_packages.version | The version of the software package. | keyword |
| aws.securityhub_findings.workflow.state | The workflow state of a finding. | keyword |
| aws.securityhub_findings.workflow.status | The status of the investigation into the finding. | keyword |
| cloud.image.id | Image ID for the cloud instance. | keyword |
| cloud.provider | Name of the cloud provider. Example values are aws, azure, gcp, or digitalocean. | constant_keyword |
| data_stream.dataset | The field can contain anything that makes sense to signify the source of the data. Examples include nginx.access, prometheus, endpoint etc. For data streams that otherwise fit, but that do not have dataset set we use the value "generic" for the dataset value. event.dataset should have the same value as data_stream.dataset. Beyond the Elasticsearch data stream naming criteria noted above, the dataset value has additional restrictions: * Must not contain - * No longer than 100 characters |
constant_keyword |
| data_stream.namespace | A user defined namespace. Namespaces are useful to allow grouping of data. Many users already organize their indices this way, and the data stream naming scheme now provides this best practice as a default. Many users will populate this field with default. If no value is used, it falls back to default. Beyond the Elasticsearch index naming criteria noted above, namespace value has the additional restrictions: * Must not contain - * No longer than 100 characters |
constant_keyword |
| data_stream.type | An overarching type for the data stream. Currently allowed values are "logs" and "metrics". We expect to also add "traces" and "synthetics" in the near future. | constant_keyword |
| event.dataset | Name of the dataset. If an event source publishes more than one type of log or events (e.g. access log, error log), the dataset is used to specify which one the event comes from. It's recommended but not required to start the dataset name with the module name, followed by a dot, then the dataset name. | constant_keyword |
| event.kind | This is one of four ECS Categorization Fields, and indicates the highest level in the ECS category hierarchy. event.kind gives high-level information about what type of information the event contains, without being specific to the contents of the event. For example, values of this field distinguish alert events from metric events. The value of this field can be used to inform how these kinds of events should be handled. They may warrant different retention, different access control, it may also help understand whether the data is coming in at a regular interval or not. |
keyword |
| event.module | Name of the module this data is coming from. If your monitoring agent supports the concept of modules or plugins to process events of a given source (e.g. Apache logs), event.module should contain the name of this module. |
constant_keyword |
| host.containerized | If the host is a container. | boolean |
| host.os.build | OS build information. | keyword |
| host.os.codename | OS codename, if any. | keyword |
| input.type | Input type | keyword |
| log.offset | Log offset | long |
| observer.vendor | Vendor name of the observer. | constant_keyword |
| resource.id | keyword | |
| resource.name | keyword | |
| resource.type | keyword | |
| result.evaluation | keyword | |
| rule.remediation | keyword | |
| url.user_info | keyword |
This is the securityhub_findings_full_posture data stream.
Example
{
"@timestamp": "2025-12-09T05:41:36.060358393Z",
"agent": {
"ephemeral_id": "2fc81c8f-5b52-4a9c-93d7-85d9dedab857",
"id": "a97254ef-b03a-4701-8ffd-0d94d12aa849",
"name": "elastic-agent-75964",
"type": "filebeat",
"version": "8.19.4"
},
"aws": {
"securityhub_findings_full_posture": {
"action": {
"port_probe": {
"blocked": false,
"details": [
{
"local": {
"ip": {
"address_v4": "1.128.0.0"
},
"port": {
"name": "HTTP",
"number": 80
}
},
"remote_ip": {
"city": {
"name": "Example City"
},
"country": {
"name": "Example Country"
},
"geolocation": {
"latitude": 0,
"longitude": 0
},
"organization": {
"asn": "64496",
"asn_organization": "ExampleASO",
"internet_provider": "ExampleOrg",
"internet_service_provider": "ExampleISP"
}
}
}
]
}
},
"aws_account_id": "111111111111",
"company": {
"name": "AWS"
},
"compliance": {
"related_requirements": [
"Req1",
"Req2"
],
"status": "PASSED",
"status_reasons": [
{
"description": "CloudWatch alarms do not exist in the account",
"reason_code": "CLOUDWATCH_ALARMS_NOT_PRESENT"
}
]
},
"confidence": 42,
"criticality": 99,
"description": "The version of openssl found on instance i-abcd1234 is known to contain a vulnerability.",
"first_observed_at": "2017-03-22T13:22:13.933Z",
"generator": {
"id": "acme-vuln-9ab348"
},
"last_observed_at": "2017-03-23T13:22:13.933Z",
"malware": [
{
"name": "Stringler",
"path": "/usr/sbin/stringler",
"state": "OBSERVED",
"type": "COIN_MINER"
}
],
"network": {
"open_port_range": {
"begin": 443,
"end": 443
}
},
"network_path": [
{
"component": {
"id": "abc-01a234bc56d8901ee",
"type": "AWS::EC2::InternetGateway"
},
"egress": {
"destination": {
"address": [
"1.128.0.0/24"
],
"port_ranges": [
{
"begin": 443,
"end": 443
}
]
},
"protocol": "TCP",
"source": {
"address": [
"175.16.199.1/24"
]
}
},
"ingress": {
"destination": {
"address": [
"175.16.199.1/24"
],
"port_ranges": [
{
"begin": 443,
"end": 443
}
]
},
"protocol": "TCP",
"source": {
"address": [
"175.16.199.1/24"
]
}
}
}
],
"note": {
"text": "Don't forget to check under the mat.",
"updated_at": "2018-08-31T00:15:09.000Z",
"updated_by": "jsmith"
},
"patch_summary": {
"failed": {
"count": 0
},
"id": "pb-123456789098",
"installed": {
"count": 100,
"other": {
"count": 1023
},
"pending_reboot": 0,
"rejected": {
"count": 0
}
},
"missing": {
"count": 100
},
"operation": {
"end_time": "2018-09-27T23:39:31.000Z",
"start_time": "2018-09-27T23:37:31.000Z",
"type": "Install"
},
"reboot_option": "RebootIfNeeded"
},
"product": {
"arn": "arn:aws:securityhub:us-east-1:111111111111:product/111111111111/default",
"fields": {
"Service_Name": "cloudtrail.amazonaws.com",
"aws/inspector/AssessmentTargetName": "My prod env",
"aws/inspector/AssessmentTemplateName": "My daily CVE assessment",
"aws/inspector/RulesPackageName": "Common Vulnerabilities and Exposures",
"generico/secure-pro/Count": "6"
},
"name": "Security Hub"
},
"provider_fields": {
"confidence": 42,
"criticality": 99,
"related_findings": [
{
"id": "123e4567-e89b-12d3-a456-426655440000",
"product": {
"arn": "arn:aws:securityhub:us-west-2::product/aws/guardduty"
}
}
],
"severity": {
"label": "MEDIUM",
"original": "MEDIUM"
},
"types": [
"Software and Configuration Checks/Vulnerabilities/CVE"
]
},
"record_state": "ACTIVE",
"region": "us-east-1",
"related_findings": [
{
"id": "123e4567-e89b-12d3-a456-426655440000",
"product": {
"arn": "arn:aws:securityhub:us-west-2::product/aws/guardduty"
}
},
{
"id": "AcmeNerfHerder-111111111111-x189dx7824",
"product": {
"arn": "arn:aws:securityhub:us-west-2::product/aws/guardduty"
}
}
],
"remediation": {
"recommendation": {
"text": "Run sudo yum update and cross your fingers and toes.",
"url": "http://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html"
}
},
"resources": [
{
"Details": {
"IamInstanceProfileArn": "arn:aws:iam::123456789012:role/IamInstanceProfileArn",
"ImageId": "ami-79fd7eee",
"IpV4Addresses": [
"175.16.199.1"
],
"IpV6Addresses": [
"2a02:cf40::"
],
"KeyName": "testkey",
"LaunchedAt": "2018-09-29T01:25:54Z",
"MetadataOptions": {
"HttpEndpoint": "enabled",
"HttpProtocolIpv6": "enabled",
"HttpPutResponseHopLimit": 1,
"HttpTokens": "optional",
"InstanceMetadataTags": "disabled"
},
"NetworkInterfaces": [
{
"NetworkInterfaceId": "eni-e5aa89a3"
}
],
"SubnetId": "PublicSubnet",
"Type": "i3.xlarge",
"VirtualizationType": "hvm",
"VpcId": "TestVPCIpv6"
},
"Id": "i-cafebabe",
"Partition": "aws",
"Region": "us-west-2",
"Tags": {
"billingCode": "Lotus-1-2-3",
"needsPatching": "true"
},
"Type": "AwsEc2Instance"
}
],
"sample": true,
"schema": {
"version": "2018-10-08"
},
"severity": {
"label": "CRITICAL",
"original": "8.3"
},
"source_url": "http://threatintelweekly.org/backdoors/8888",
"threat_intel_indicators": [
{
"category": "BACKDOOR",
"source": "Threat Intel Weekly",
"source_url": "http://threatintelweekly.org/backdoors/8888",
"value": "175.16.199.1"
}
],
"title": "EC2.20 Both VPN tunnels for an AWS Site-to-Site VPN connection should be up",
"types": [
"Software and Configuration Checks/Vulnerabilities/CVE"
],
"updated_at": "2018-08-31T00:15:09.000Z",
"user_defined_fields": {
"comeBackToLater": "Check this again on Monday",
"reviewedByCio": "true"
},
"verification_state": "UNKNOWN",
"vulnerabilities": [
{
"cvss": [
{
"base_score": 4.7,
"base_vector": "AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N",
"version": "V3"
},
{
"base_score": 4.7,
"base_vector": "AV:L/AC:M/Au:N/C:C/I:N/A:N",
"version": "V2"
}
],
"related_vulnerabilities": [
"CVE-2020-12345"
],
"vendor": {
"created_at": "2020-01-16T00:01:43.000Z",
"severity": "Medium",
"updated_at": "2020-01-16T00:01:43.000Z",
"url": "https://alas.aws.amazon.com/ALAS-2020-1337.html"
},
"vulnerable_packages": [
{
"architecture": "x86_64",
"epoch": "1",
"name": "openssl",
"release": "16.amzn2.0.3",
"version": "1.0.2k"
}
]
}
],
"workflow": {
"state": "NEW",
"status": "NEW"
}
}
},
"cloud": {
"account": {
"id": "111111111111"
},
"instance": {
"id": "i-cafebabe",
"name": "i-cafebabe"
},
"provider": "aws",
"region": "us-east-1"
},
"data_stream": {
"dataset": "aws.securityhub_findings_full_posture",
"namespace": "28602",
"type": "logs"
},
"destination": {
"domain": "example2.com",
"ip": [
"1.128.0.0",
"2a02:cf40::"
],
"port": 80
},
"ecs": {
"version": "8.11.0"
},
"elastic_agent": {
"id": "a97254ef-b03a-4701-8ffd-0d94d12aa849",
"snapshot": false,
"version": "8.19.4"
},
"event": {
"action": "port_probe",
"agent_id_status": "verified",
"category": [
"configuration"
],
"created": "2025-12-09T05:41:33.075Z",
"dataset": "aws.securityhub_findings_full_posture",
"id": "us-west-2/111111111111/98aebb2207407c87f51e89943f12b1ef",
"ingested": "2025-12-09T05:41:36Z",
"kind": "state",
"original": "{\"Action\":{\"ActionType\":\"PORT_PROBE\",\"PortProbeAction\":{\"Blocked\":false,\"PortProbeDetails\":[{\"LocalIpDetails\":{\"IpAddressV4\":\"1.128.0.0\"},\"LocalPortDetails\":{\"Port\":80,\"PortName\":\"HTTP\"},\"RemoteIpDetails\":{\"City\":{\"CityName\":\"Example City\"},\"Country\":{\"CountryName\":\"Example Country\"},\"GeoLocation\":{\"Lat\":0,\"Lon\":0},\"Organization\":{\"Asn\":64496,\"AsnOrg\":\"ExampleASO\",\"Isp\":\"ExampleISP\",\"Org\":\"ExampleOrg\"}}}]}},\"AwsAccountId\":\"111111111111\",\"CompanyName\":\"AWS\",\"Compliance\":{\"RelatedRequirements\":[\"Req1\",\"Req2\"],\"Status\":\"PASSED\",\"StatusReasons\":[{\"Description\":\"CloudWatch alarms do not exist in the account\",\"ReasonCode\":\"CLOUDWATCH_ALARMS_NOT_PRESENT\"}]},\"Confidence\":42,\"CreatedAt\":\"2017-03-22T13:22:13.933Z\",\"Criticality\":99,\"Description\":\"The version of openssl found on instance i-abcd1234 is known to contain a vulnerability.\",\"FindingProviderFields\":{\"Confidence\":42,\"Criticality\":99,\"RelatedFindings\":[{\"Id\":\"123e4567-e89b-12d3-a456-426655440000\",\"ProductArn\":\"arn:aws:securityhub:us-west-2::product/aws/guardduty\"}],\"Severity\":{\"Label\":\"MEDIUM\",\"Original\":\"MEDIUM\"},\"Types\":[\"Software and Configuration Checks/Vulnerabilities/CVE\"]},\"FirstObservedAt\":\"2017-03-22T13:22:13.933Z\",\"GeneratorId\":\"acme-vuln-9ab348\",\"Id\":\"us-west-2/111111111111/98aebb2207407c87f51e89943f12b1ef\",\"LastObservedAt\":\"2017-03-23T13:22:13.933Z\",\"Malware\":[{\"Name\":\"Stringler\",\"Path\":\"/usr/sbin/stringler\",\"State\":\"OBSERVED\",\"Type\":\"COIN_MINER\"}],\"Network\":{\"DestinationDomain\":\"example2.com\",\"DestinationIpV4\":\"1.128.0.0\",\"DestinationIpV6\":\"2a02:cf40::\",\"DestinationPort\":\"80\",\"Direction\":\"IN\",\"OpenPortRange\":{\"Begin\":443,\"End\":443},\"Protocol\":\"TCP\",\"SourceDomain\":\"example1.com\",\"SourceIpV4\":\"1.128.0.0\",\"SourceIpV6\":\"2a02:cf40::\",\"SourceMac\":\"00:0d:83:b1:c0:8e\",\"SourcePort\":\"42\"},\"NetworkPath\":[{\"ComponentId\":\"abc-01a234bc56d8901ee\",\"ComponentType\":\"AWS::EC2::InternetGateway\",\"Egress\":{\"Destination\":{\"Address\":[\"1.128.0.0/24\"],\"PortRanges\":[{\"Begin\":443,\"End\":443}]},\"Protocol\":\"TCP\",\"Source\":{\"Address\":[\"175.16.199.1/24\"]}},\"Ingress\":{\"Destination\":{\"Address\":[\"175.16.199.1/24\"],\"PortRanges\":[{\"Begin\":443,\"End\":443}]},\"Protocol\":\"TCP\",\"Source\":{\"Address\":[\"175.16.199.1/24\"]}}}],\"Note\":{\"Text\":\"Don't forget to check under the mat.\",\"UpdatedAt\":\"2018-08-31T00:15:09Z\",\"UpdatedBy\":\"jsmith\"},\"PatchSummary\":{\"FailedCount\":\"0\",\"Id\":\"pb-123456789098\",\"InstalledCount\":\"100\",\"InstalledOtherCount\":\"1023\",\"InstalledPendingReboot\":\"0\",\"InstalledRejectedCount\":\"0\",\"MissingCount\":\"100\",\"Operation\":\"Install\",\"OperationEndTime\":\"2018-09-27T23:39:31Z\",\"OperationStartTime\":\"2018-09-27T23:37:31Z\",\"RebootOption\":\"RebootIfNeeded\"},\"Process\":{\"LaunchedAt\":\"2018-09-27T22:37:31Z\",\"Name\":\"syslogd\",\"ParentPid\":56789,\"Path\":\"/usr/sbin/syslogd\",\"Pid\":12345,\"TerminatedAt\":\"2018-09-27T23:37:31Z\"},\"ProductArn\":\"arn:aws:securityhub:us-east-1:111111111111:product/111111111111/default\",\"ProductFields\":{\"Service_Name\":\"cloudtrail.amazonaws.com\",\"aws/inspector/AssessmentTargetName\":\"My prod env\",\"aws/inspector/AssessmentTemplateName\":\"My daily CVE assessment\",\"aws/inspector/RulesPackageName\":\"Common Vulnerabilities and Exposures\",\"generico/secure-pro/Count\":\"6\"},\"ProductName\":\"Security Hub\",\"RecordState\":\"ACTIVE\",\"Region\":\"us-east-1\",\"RelatedFindings\":[{\"Id\":\"123e4567-e89b-12d3-a456-426655440000\",\"ProductArn\":\"arn:aws:securityhub:us-west-2::product/aws/guardduty\"},{\"Id\":\"AcmeNerfHerder-111111111111-x189dx7824\",\"ProductArn\":\"arn:aws:securityhub:us-west-2::product/aws/guardduty\"}],\"Remediation\":{\"Recommendation\":{\"Text\":\"Run sudo yum update and cross your fingers and toes.\",\"Url\":\"http://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html\"}},\"Resources\":[{\"Details\":{\"IamInstanceProfileArn\":\"arn:aws:iam::123456789012:role/IamInstanceProfileArn\",\"ImageId\":\"ami-79fd7eee\",\"IpV4Addresses\":[\"175.16.199.1\"],\"IpV6Addresses\":[\"2a02:cf40::\"],\"KeyName\":\"testkey\",\"LaunchedAt\":\"2018-09-29T01:25:54Z\",\"MetadataOptions\":{\"HttpEndpoint\":\"enabled\",\"HttpProtocolIpv6\":\"enabled\",\"HttpPutResponseHopLimit\":1,\"HttpTokens\":\"optional\",\"InstanceMetadataTags\":\"disabled\"},\"NetworkInterfaces\":[{\"NetworkInterfaceId\":\"eni-e5aa89a3\"}],\"SubnetId\":\"PublicSubnet\",\"Type\":\"i3.xlarge\",\"VirtualizationType\":\"hvm\",\"VpcId\":\"TestVPCIpv6\"},\"Id\":\"i-cafebabe\",\"Partition\":\"aws\",\"Region\":\"us-west-2\",\"Tags\":{\"billingCode\":\"Lotus-1-2-3\",\"needsPatching\":\"true\"},\"Type\":\"AwsEc2Instance\"}],\"Sample\":true,\"SchemaVersion\":\"2018-10-08\",\"Severity\":{\"Label\":\"CRITICAL\",\"Original\":\"8.3\"},\"SourceUrl\":\"http://threatintelweekly.org/backdoors/8888\",\"ThreatIntelIndicators\":[{\"Category\":\"BACKDOOR\",\"LastObservedAt\":\"2018-09-27T23:37:31Z\",\"Source\":\"Threat Intel Weekly\",\"SourceUrl\":\"http://threatintelweekly.org/backdoors/8888\",\"Type\":\"IPV4_ADDRESS\",\"Value\":\"175.16.199.1\"}],\"Threats\":[{\"FilePaths\":[{\"FileName\":\"b.txt\",\"FilePath\":\"/tmp/b.txt\",\"Hash\":\"sha256\",\"ResourceId\":\"arn:aws:ec2:us-west-2:123456789012:volume/vol-032f3bdd89aee112f\"}],\"ItemCount\":3,\"Name\":\"Iot.linux.mirai.vwisi\",\"Severity\":\"HIGH\"}],\"Title\":\"EC2.20 Both VPN tunnels for an AWS Site-to-Site VPN connection should be up\",\"Types\":[\"Software and Configuration Checks/Vulnerabilities/CVE\"],\"UpdatedAt\":\"2018-08-31T00:15:09Z\",\"UserDefinedFields\":{\"comeBackToLater\":\"Check this again on Monday\",\"reviewedByCio\":\"true\"},\"VerificationState\":\"UNKNOWN\",\"Vulnerabilities\":[{\"Cvss\":[{\"BaseScore\":4.7,\"BaseVector\":\"AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N\",\"Version\":\"V3\"},{\"BaseScore\":4.7,\"BaseVector\":\"AV:L/AC:M/Au:N/C:C/I:N/A:N\",\"Version\":\"V2\"}],\"Id\":\"CVE-2020-12345\",\"ReferenceUrls\":[\"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12418\",\"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17563\"],\"RelatedVulnerabilities\":[\"CVE-2020-12345\"],\"Vendor\":{\"Name\":\"Alas\",\"Url\":\"https://alas.aws.amazon.com/ALAS-2020-1337.html\",\"VendorCreatedAt\":\"2020-01-16T00:01:43Z\",\"VendorSeverity\":\"Medium\",\"VendorUpdatedAt\":\"2020-01-16T00:01:43Z\"},\"VulnerablePackages\":[{\"Architecture\":\"x86_64\",\"Epoch\":\"1\",\"Name\":\"openssl\",\"Release\":\"16.amzn2.0.3\",\"Version\":\"1.0.2k\"}]}],\"Workflow\":{\"Status\":\"NEW\"},\"WorkflowState\":\"NEW\"}",
"outcome": "success",
"type": [
"info"
]
},
"host": {
"id": "i-cafebabe"
},
"input": {
"type": "httpjson"
},
"network": {
"direction": "inbound",
"protocol": "tcp"
},
"observer": {
"vendor": "AWS Security Hub CSPM"
},
"organization": {
"name": "AWS"
},
"process": {
"end": "2018-09-27T23:37:31.000Z",
"executable": "/usr/sbin/syslogd",
"name": "syslogd",
"parent": {
"pid": 56789
},
"pid": 12345,
"start": "2018-09-27T22:37:31.000Z"
},
"related": {
"ip": [
"1.128.0.0",
"2a02:cf40::"
]
},
"resource": {
"id": "i-cafebabe",
"name": "i-cafebabe",
"type": "AwsEc2Instance"
},
"result": {
"evaluation": "passed"
},
"rule": {
"description": "The version of openssl found on instance i-abcd1234 is known to contain a vulnerability.",
"id": "acme-vuln-9ab348",
"name": "EC2.20 Both VPN tunnels for an AWS Site-to-Site VPN connection should be up",
"reference": "http://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html",
"remediation": "Run sudo yum update and cross your fingers and toes.\r\nhttp://myfp.com/recommendations/dangerous_things_and_how_to_fix_them.html",
"ruleset": [
"Req1",
"Req2"
]
},
"source": {
"domain": "example1.com",
"ip": [
"1.128.0.0",
"2a02:cf40::"
],
"mac": "00-0D-83-B1-C0-8E",
"port": 42
},
"tags": [
"preserve_original_event",
"forwarded",
"aws_securityhub_findings_full_posture"
],
"threat": {
"indicator": {
"last_seen": "2018-09-27T23:37:31.000Z",
"type": "ipv4-addr"
}
},
"url": {
"domain": "threatintelweekly.org",
"full": "http://threatintelweekly.org/backdoors/8888",
"original": "http://threatintelweekly.org/backdoors/8888",
"path": "/backdoors/8888",
"scheme": "http"
},
"vulnerability": {
"id": "CVE-2020-12345",
"reference": [
"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-12418",
"http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-17563"
],
"scanner": {
"vendor": "Alas"
},
"score": {
"base": 4.7,
"version": "V2"
}
}
}
ECS Field Reference
Please refer to the following document for detailed information on ECS fields.
Exported fields
| Field | Description | Type |
|---|---|---|
| @timestamp | Date/time when the event originated. This is the date/time extracted from the event, typically representing when the event was generated by the source. If the event source has no original timestamp, this value is typically populated by the first time the event was received by the pipeline. Required field for all events. | date |
| aws.securityhub_findings_full_posture.action.aws_api_call.affected_resources | Identifies the resources that were affected by the API call. | flattened |
| aws.securityhub_findings_full_posture.action.aws_api_call.api | The name of the API method that was issued. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.caller.type | Indicates whether the API call originated from a remote IP address(remoteip) or from a DNS domain(domain). | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.domain_details.domain | The name of the DNS domain that issued the API call. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.first_seen | An ISO8601-formatted timestamp that indicates when the API call was first observed. | date |
| aws.securityhub_findings_full_posture.action.aws_api_call.last_seen | An ISO8601-formatted timestamp that indicates when the API call was most recently observed. | date |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.city.name | The name of the city. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.country.code | The 2-letter ISO 3166 country code for the country. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.country.name | The name of the country. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.geolocation.latitude | The longitude of the location. | double |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.geolocation.longitude | The latitude of the location. | double |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.organization.asn | The Autonomous System Number(ASN) of the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.organization.asn_organization | The name of the organization that registered the ASN. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.organization.internet_provider | The ISP information for the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.remote_ip.organization.internet_service_provider | The name of the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.aws_api_call.service.name | The name of the Amazon Web Services service that the API method belongs to. | keyword |
| aws.securityhub_findings_full_posture.action.dns_request.blocked | Indicates whether the DNS request was blocked. | boolean |
| aws.securityhub_findings_full_posture.action.dns_request.domain | The DNS domain that is associated with the DNS request. | keyword |
| aws.securityhub_findings_full_posture.action.dns_request.protocol | The protocol that was used for the DNS request. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.blocked | Indicates whether the network connection attempt was blocked. | boolean |
| aws.securityhub_findings_full_posture.action.network_connection.direction | The direction of the network connection request(IN or OUT). | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.local.port.name | The port name of the local connection. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.local.port.number | The number of the port. | long |
| aws.securityhub_findings_full_posture.action.network_connection.protocol | The protocol used to make the network connection request. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote.port.name | The port name of the remote connection. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote.port.number | The number of the port. | long |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.city.name | The name of the city. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.country.code | The 2-letter ISO 3166 country code for the country. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.country.name | The name of the country. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.geolocation.latitude | The longitude of the location. | double |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.geolocation.longitude | The latitude of the location. | double |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.organization.asn | The Autonomous System Number(ASN) of the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.organization.asn_organization | The name of the organization that registered the ASN. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.organization.internet_provider | The ISP information for the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.network_connection.remote_ip.organization.internet_service_provider | The name of the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.blocked | Indicates whether the port probe was blocked. | boolean |
| aws.securityhub_findings_full_posture.action.port_probe.details.local.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings_full_posture.action.port_probe.details.local.port.name | The port name of the local connection. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.details.local.port.number | The number of the port. | long |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.city.name | The name of the city. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.country.code | The 2-letter ISO 3166 country code for the country. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.country.name | The name of the country. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.geolocation.latitude | The longitude of the location. | double |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.geolocation.longitude | The latitude of the location. | double |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.ip.address_v4 | The IP address. | ip |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.organization.asn | The Autonomous System Number(ASN) of the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.organization.asn_organization | The name of the organization that registered the ASN. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.organization.internet_provider | The ISP information for the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.port_probe.details.remote_ip.organization.internet_service_provider | The name of the internet provider. | keyword |
| aws.securityhub_findings_full_posture.action.type | The type of action that was detected. | keyword |
| aws.securityhub_findings_full_posture.aws_account_id | The Amazon Web Services account ID that a finding is generated in. | keyword |
| aws.securityhub_findings_full_posture.company.name | The name of the company for the product that generated the finding. | keyword |
| aws.securityhub_findings_full_posture.compliance.related_requirements | For a control, the industry or regulatory framework requirements that are related to the control. | keyword |
| aws.securityhub_findings_full_posture.compliance.security_control_id | Unique identifier of a control across standards. | keyword |
| aws.securityhub_findings_full_posture.compliance.status | The result of a standards check. | keyword |
| aws.securityhub_findings_full_posture.compliance.status_reasons.description | The corresponding description for the status reason code. | keyword |
| aws.securityhub_findings_full_posture.compliance.status_reasons.reason_code | A code that represents a reason for the control status. | keyword |
| aws.securityhub_findings_full_posture.confidence | A finding's confidence. Confidence is defined as the likelihood that a finding accurately identifies the behavior or issue that it was intended to identify. | long |
| aws.securityhub_findings_full_posture.created_at | Indicates when the security-findings provider created the potential security issue that a finding captured. | date |
| aws.securityhub_findings_full_posture.criticality | The level of importance assigned to the resources associated with the finding. | long |
| aws.securityhub_findings_full_posture.description | A finding's description. | keyword |
| aws.securityhub_findings_full_posture.first_observed_at | Indicates when the security-findings provider first observed the potential security issue that a finding captured. | date |
| aws.securityhub_findings_full_posture.generator.id | The identifier for the solution-specific component(a discrete unit of logic) that generated a finding. In various security-findings providers' solutions, this generator can be called a rule, a check, a detector, a plugin, etc. | keyword |
| aws.securityhub_findings_full_posture.id | The security findings provider-specific identifier for a finding. | keyword |
| aws.securityhub_findings_full_posture.last_observed_at | Indicates when the security-findings provider most recently observed the potential security issue that a finding captured. | date |
| aws.securityhub_findings_full_posture.malware.name | The name of the malware that was observed. | keyword |
| aws.securityhub_findings_full_posture.malware.path | The file system path of the malware that was observed. | keyword |
| aws.securityhub_findings_full_posture.malware.state | The state of the malware that was observed. | keyword |
| aws.securityhub_findings_full_posture.malware.type | The type of the malware that was observed. | keyword |
| aws.securityhub_findings_full_posture.network.destination.domain | The destination domain of network-related information about a finding. | keyword |
| aws.securityhub_findings_full_posture.network.destination.ip.v4 | The destination IPv4 address of network-related information about a finding. | ip |
| aws.securityhub_findings_full_posture.network.destination.ip.v6 | The destination IPv6 address of network-related information about a finding. | ip |
| aws.securityhub_findings_full_posture.network.destination.port | The destination port of network-related information about a finding. | long |
| aws.securityhub_findings_full_posture.network.direction | The direction of network traffic associated with a finding. | keyword |
| aws.securityhub_findings_full_posture.network.open_port_range.begin | The first port in the port range. | long |
| aws.securityhub_findings_full_posture.network.open_port_range.end | The last port in the port range. | long |
| aws.securityhub_findings_full_posture.network.protocol | The protocol of network-related information about a finding. | keyword |
| aws.securityhub_findings_full_posture.network.source.domain | The source domain of network-related information about a finding. | keyword |
| aws.securityhub_findings_full_posture.network.source.ip.v4 | The source IPv4 address of network-related information about a finding. | ip |
| aws.securityhub_findings_full_posture.network.source.ip.v6 | The source IPv6 address of network-related information about a finding. | ip |
| aws.securityhub_findings_full_posture.network.source.mac | The source media access control(MAC) address of network-related information about a finding. | keyword |
| aws.securityhub_findings_full_posture.network.source.port | The source port of network-related information about a finding. | long |
| aws.securityhub_findings_full_posture.network_path.component.id | The identifier of a component in the network path. | keyword |
| aws.securityhub_findings_full_posture.network_path.component.type | The type of component. | keyword |
| aws.securityhub_findings_full_posture.network_path.egress.destination.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings_full_posture.network_path.egress.destination.port_ranges.begin | The first port in the port range. | long |
| aws.securityhub_findings_full_posture.network_path.egress.destination.port_ranges.end | The last port in the port range. | long |
| aws.securityhub_findings_full_posture.network_path.egress.protocol | The protocol used for the component. | keyword |
| aws.securityhub_findings_full_posture.network_path.egress.source.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings_full_posture.network_path.egress.source.port_ranges.begin | The first port in the port range. | long |
| aws.securityhub_findings_full_posture.network_path.egress.source.port_ranges.end | The last port in the port range. | long |
| aws.securityhub_findings_full_posture.network_path.ingress.destination.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings_full_posture.network_path.ingress.destination.port_ranges.begin | The first port in the port range. | long |
| aws.securityhub_findings_full_posture.network_path.ingress.destination.port_ranges.end | The last port in the port range. | long |
| aws.securityhub_findings_full_posture.network_path.ingress.protocol | The protocol used for the component. | keyword |
| aws.securityhub_findings_full_posture.network_path.ingress.source.address | The IP addresses of the destination. | keyword |
| aws.securityhub_findings_full_posture.network_path.ingress.source.port_ranges.begin | The first port in the port range. |