Data Formats Software for ChromeOS

Browse free open source Data Formats software and projects for ChromeOS below. Use the toggles on the left to filter open source Data Formats software by OS, license, language, programming language, and project status.

  • Custom VMs From 1 to 96 vCPUs With 99.95% Uptime Icon
    Custom VMs From 1 to 96 vCPUs With 99.95% Uptime

    General-purpose, compute-optimized, or GPU/TPU-accelerated. Built to your exact specs.

    Live migration and automatic failover keep workloads online through maintenance. One free e2-micro VM every month.
    Start Free
  • Build Agents and Models on One Platform Icon
    Build Agents and Models on One Platform

    Everything you need to build production-ready agents and models. Access 200+ Google and third-party AI models and tools.

    Gemini Enterprise Agent Platform is Google Cloud's comprehensive platform for developers to build, scale, govern, and optimize agents and models. Choose from Google's most advanced models and third-party models like Anthropic's Claude Model Family.
    Start Free
  • 1

    Expat XML Parser

    Fast XML parser library in C

    PLEASE NOTE that we are in the process of moving to GitHub: https://github.com/libexpat/libexpat This is James Clark's Expat XML parser library in C. It is a stream oriented parser that requires setting handlers to deal with the structure that the parser discovers in the document. PLEASE NOTE that we are in the process of moving to GitHub: https://github.com/libexpat/libexpat
    Leader badge
    Downloads: 1,102 This Week
    Last Update:
    See Project
  • 2
    gSOAP Toolkit

    gSOAP Toolkit

    Development toolkit for Web Services and XML data bindings for C & C++

    The gSOAP toolkit is an extensive suite of portable C and C++ software to develop XML Web services with powerful type-safe XML data bindings. Easy-to-use code-generator tools allow you to directly integrate XML data in C and C++. Serializes native application data in XML. Includes WSDL/XSD schema binding and auto-coding tools, stub/skeleton compiler, Web server integration with Apache module and IIS extension, high-performance XML processing with schema validation, fast MIME/MTOM streaming, SOAP and REST Web API development, WS-* protocols (WS-Security, WS-Policy, WS-ReliableMessaging, etc), XML-RPC and JSON. Licensed under GPLv2. Visit the developer center with guides, tutorials, and examples at www.genivia.com/dev.html The documentation of the toolkit, libraries, plugins and more is available at www.genivia.com/docs.html Commercial-use licenses and expert technical support services are available at competitive pricing levels, please visit www.genivia.com/products.html
    Leader badge
    Downloads: 603 This Week
    Last Update:
    See Project
  • 3
    Rapid YAML

    Rapid YAML

    Library to parse and emit YAML, and do it fast

    Or ryml, for short. ryml is a C++ library to parse and emit YAML, and do it fast, on everything from x64 to bare-metal chips without operating system. (If you are looking to use your programs with a YAML tree as a configuration tree with override facilities, take a look at c4conf). ryml parses both read-only and in-situ source buffers; the resulting data nodes hold only views to sub-ranges of the source buffer. No string copies or duplications are done, and no virtual functions are used. The data tree is a flat index-based structure stored in a single array. Serialization happens only at your direct request, after parsing / before emitting. Internally, the data tree representation stores only string views and has no knowledge of types, but of course, every node can have a YAML type tag. ryml makes it easy and fast to read and modify the data tree.
    Downloads: 66 This Week
    Last Update:
    See Project
  • 4

    QuaZIP

    A C++/Qt ZIP library

    Moved to GitHub: https://github.com/stachenov/quazip
    Leader badge
    Downloads: 330 This Week
    Last Update:
    See Project
  • Demo Series - Small Business Backup By Veeam Icon
    Demo Series - Small Business Backup By Veeam

    Learn how to protect your Microsoft 365 data, with simple, actionable tips today.

    Watch this on-demand demo series and learn how to protect your Microsoft 365 data with clear, simple, actionable steps that are easy to implement for businesses of all sizes.
    Watch Demo Series
  • 5
    lxml

    lxml

    The lxml XML toolkit for Python

    A Python library for efficient XML and HTML processing, known for speed and compatibility. The lxml XML toolkit is a Pythonic binding for the C libraries libxml2 and libxslt. It is unique in that it combines the speed and XML feature completeness of these libraries with the simplicity of a native Python API, mostly compatible but superior to the well-known ElementTree API. The latest release works with all CPython versions from 3.6 to 3.12. See the introduction for more information about the background and goals of the lxml project.
    Downloads: 61 This Week
    Last Update:
    See Project
  • 6
    libmng -THE reference library for reading, displaying, writing and examining Multiple-Image Network Graphics. MNG is the animation extension to the popular PNG image-format.
    Leader badge
    Downloads: 1,326 This Week
    Last Update:
    See Project
  • 7
    Grassroots DICOM

    Grassroots DICOM

    Cross-platform DICOM implementation

    Grassroots DiCoM is a C++ library for DICOM medical files. It is accessible from Python, C#, Java and PHP. It supports RAW, JPEG, JPEG 2000, JPEG-LS, RLE and deflated transfer syntax. It comes with a super fast scanner implementation to quickly scan hundreds of DICOM files. It supports SCU network operations (C-ECHO, C-FIND, C-STORE, C-MOVE). PS 3.3 & 3.6 are distributed as XML files. It also provides PS 3.15 certificates and password based mecanism to anonymize and de-identify DICOM datasets.
    Leader badge
    Downloads: 187 This Week
    Last Update:
    See Project
  • 8
    Kile LaTeX Editor

    Kile LaTeX Editor

    Kile is a feature-rich LaTeX editor

    Kile is a LaTeX editor, a TeX shell that simplifies the creation of LaTeX documents.
    Leader badge
    Downloads: 117 This Week
    Last Update:
    See Project
  • 9
    Event Ruler

    Event Ruler

    Java library that allows matching many thousands of Events per second

    Event Ruler (called Ruler in the rest of the doc for brevity) is a Java library that allows matching Rules to Events. An event is a list of fields, which may be given as name/value pairs or as a JSON object. A rule associates event field names with lists of possible values. Event Ruler is a Java library that allows matching many thousands of Events per second to any number of expressive and sophisticated rules.
    Downloads: 18 This Week
    Last Update:
    See Project
  • One Monitoring Tool for IT, OT and Cloud | Free Trial Icon
    One Monitoring Tool for IT, OT and Cloud | Free Trial

    Vendor-agnostic monitoring across on-prem servers, cloud platforms and OT devices, all in one dashboard. No more tool sprawl.

    Modern infrastructure spans data centers, cloud platforms and factory floors, and every blind spot between them is a risk. PRTG supports SNMP, WMI, SSH and other standard protocols to monitor IT, OT and hybrid environments through one customizable dashboard. Build the views your team needs, from network health to application performance, without switching tools. Try PRTG free for 30 days now.
    Try PRTG Free
  • 10
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 15 This Week
    Last Update:
    See Project
  • 11
    adventure

    adventure

    A user-interface library, formerly known as text, for Minecraft

    Adventure is a library for server-controllable user interface elements in Minecraft: Java Edition. The Adventure documentation should be used alongside the Javadocs. If you have further questions, feel free to join our Discord. Most users will want to use Adventure as a component of an existing modding platform. The best integrated are our Native Support, but we also support other platforms via adapters.
    Downloads: 12 This Week
    Last Update:
    See Project
  • 12

    XLSX I/O

    C library for reading/writing values from/to Excel .xlsx files.

    Cross-platform C library for reading values from and writing values to .xlsx files. XLSX I/O aims to provide a C library for reading and writing .xlsx files. The .xlsx file format is the native format used by Microsoft(R) Excel(TM) since version 2007. The library was written with the following goals in mind: - primary focus on data values organized in tables, on not layout or graphics - written in standard C, but allows being used by C++ - simple interface - small footprint - portable across different platforms (Windows, *nix) - minimal dependancies: only depends on expat (only for reading) and libzip (which in turn depends on zlib) - separate library for reading and writing .xlsx files Also includes command line tools to convert between .xslx and CSV files.
    Leader badge
    Downloads: 95 This Week
    Last Update:
    See Project
  • 13
    CoreUI

    CoreUI

    Open Source UI Kit built on top of Bootstrap 5 and plain JavaScript

    CoreUI Admin Panel is not another blend of 3rd parties free components and libraries. It's the only Open Source Bootstrap Admin Dashboard Template built on the enterprise-grade hand-crafted UI Components Library created and backed by professionals. CoreUI and CoreUI PRO are delivered with fully-featured, and ready-to-use admin panel templates for your application. Save thousands of development hours by using ready-made, reusable, and commonly used widgets and UI components. Moreover, CoreUI Bootstrap Admin Template is delivered with a ready-to-use environment, so you don't have to waste time configuring the project. All build scripts and tools are ready to use out of the box. With CoreUI Template you can start a new project in a minute!
    Downloads: 9 This Week
    Last Update:
    See Project
  • 14
    TreeFrog Framework

    TreeFrog Framework

    TreeFrog Framework, High-speed C++ MVC Framework for Web Applications

    TreeFrog Framework is a high-speed and full-stack C++ framework for developing Web applications, which supports HTTP and WebSocket protocol. Web applications can run faster than that of scripting language because the server-side framework was written in C++/Qt. In application development, it provides an O/R mapping system and template systems on an MVC architecture, aims to achieve high productivity through the policy of convention over configuration. TreeFrog Framework is cross-platform. It runs on Windows, of course, but also on UNIX-like Operating Systems, macOS, and Linux. Using Windows open-source coding, it is possible to support Linux. Web applications that run on multiple platforms are also possible, simply by recompiling the source code. TreeFrog Framework is open-source software, under the new BSD license (3-clause BSD License).
    Downloads: 8 This Week
    Last Update:
    See Project
  • 15
    LaTeXDraw

    LaTeXDraw

    Vector drawing program for LaTeX using PSTricks

    LaTeXDraw is a graphical drawing editor for LaTeX. LaTeXDraw can be used to 1) generate PSTricks code; 2) directly create PDF or PS pictures.
    Leader badge
    Downloads: 40 This Week
    Last Update:
    See Project
  • 16
    Sesame

    Sesame

    Java RDF Framework

    This project is no longer actively maintained. It is succeeded by the Eclipse RDF4J project, which can be found at GitHub and at http://www.rdf4j.org/. Sesame is a de-facto standard framework for processing RDF data. This includes parsing, scalable storage, reasoning and full SPARQL 1.1 query/update support. Sesame offers a fully modular toolkit and an easy-to-use Java API that can be connected to all leading RDF storage solutions.
    Leader badge
    Downloads: 31 This Week
    Last Update:
    See Project
  • 17
    Lexbor

    Lexbor

    Lexbor is development of an open source HTML Renderer library

    Lexbor is the development of a web browser engine available as a software library; it ships with a free license and has no extra dependencies. For us, speed is an absolute must-have. In our development process, we focus on fastest parsing techniques for HTML, CSS, and fonts, fastest data processing methods, and fastest ways to serve content to end users. Whether you are building a backend that handles millions of HTML documents or a UI-heavy user app, your software’s response rate always matters to users and developers alike. Lexbor’s code is optimized for ease of access in end-user applications and across programming languages. You can effortlessly wrap all the capabilities of the library in, say, Python to power your end-user or backend applications in a new environment. In other words, lexbor offers a feature-rich core that developers can build upon as they see fit.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 18
    Vanilla Framework

    Vanilla Framework

    From community websites to web applications, this CSS framework

    Backed by open-source code and written in Sass by the Canonical Web Team. Vanilla contains a responsive CSS grid, basic style for HTML elements and a selection of key useful patterns and utility classes that you can extend. Designed to be composable, you can include the whole framework to avail of all styles or you can use only what you need for your project. Anyone can contribute to Vanilla, improve it and extend it. All the code is available on GitHub and is licensed under LGPLv3 by Canonical.
    Downloads: 6 This Week
    Last Update:
    See Project
  • 19

    Okapi Framework (Old .NET version)

    See http://okapi.opentag.com/ for LATES VERSION of the Okapi Framework

    THIS VERSION ON SOURCEFORGE IS NO LONGER SUPPORTED and works only on Windows. The Okapi Framework is a set of components and tools for localization and translation tasks. THE NEWEST JAVA-BASED VERSION OF OKAPI IS AVAILABLE AT: http://okapi.opentag.com/ The new version runs on Windows, Mac, Linux, etc.
    Leader badge
    Downloads: 45 This Week
    Last Update:
    See Project
  • 20

    RecordEditor

    Editor for Fixed Width, Csv and Existing Xml files.

    The RecordEditor is a Data File editor for Flat Files (delimited and fixed field position). It supports Unix / PC / Legacy (e.g. Mainframe) file formats, both Text and binary files. The Editor uses a Record-Layout description to format the files. This is ideal for Fixed width (Text or Binary) files, Cobol Data Files, Mainframe files and complicated Csv files. Cobol Copybooks can be used to format Cobol Data files. As well as an editor, The following utilities are supplied * Formatted Compare * File Copy and reformat Utility * FileWizard this is use to work out the format of a File. It can generally find both Text and binary / packed deicimal fields in a file For Simple Csv you should look at its sister project reCsvEditor. Note: The core Editor code is also used in the "Protocol buffers editor" and "Avro Editor"
    Leader badge
    Downloads: 28 This Week
    Last Update:
    See Project
  • 21
    Cutelyst

    Cutelyst

    Web Framework built on top of Qt, using the approach of Catalyst

    Create fast and modern web applications that share the same code as your desktop or mobile apps. Why have two or more development teams focused on a specific platform when you can have a single team coding the same code, sharing skills and lines of code. With Qt, you already can write applications for Windows, Linux, Android, MacOS, and iOS using the same source code, Cutelyst allows you to share your C++ code with your web application. Cutelyst has a WSGI server that supports HTTP/1.1, HTTP/2, FastCGI, and WebSockets, it can even be embedded in your application if you like. It also features a plugin for uWSGI which gives us support for HTTP/1.0, FastCGI, and uWSGI protocols but is slower and doesn't support WebSockets. Running standalone or behind a web server is really easy. With your application logic written in C++ your application get's really small, a full CMS (like this one) uses around 5MB of RAM which can be shared with other instances of the same application.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 22
    Hateoas

    Hateoas

    A PHP library to support implementing representations

    A PHP library to support implementing representations for HATEOAS REST web services.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 23
    Marx

    Marx

    The classless CSS reset (perfect for Communists)

    Marx is a CSS stylesheet to be used in any project (namely small ones). If you don't need the weight of heavy frameworks or you would just like to make an edible website quickly, Marx is perfect for you. It can be used out of the minified box but it can also be customized and styled through the use of HTML classes. Built atop of Sanitize.css, meaning all browsers render consistently. Responsive and mobile-friendly. Clean, beautiful typography. Forms, tables, buttons and navigation. Zero classes, so it already works with your HTML. Drop-dead gorgeous.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 24
    Vexip UI

    Vexip UI

    Vue 3 UI library, highly customizability, full TypeScript, performance

    Highly customizability, full TypeScript, performance pretty good. This library is using base on vue 3.0 with using composition api, and design and code components in the traditional way by Vue possible, fully TypeScript. Almost all the default value of props for each component can be quickly modified by configuration, for easy customization. And, the writing of component codes pays great attention to lowering the threshold of source code reading, and the style of code is as close to the usual business code habits as possible to avoid dazzling encapsulation. There are currently 70+ components, many you see everywhere are here and are better, and a few may bright your eyes.
    Downloads: 5 This Week
    Last Update:
    See Project
  • 25

    jdbc2csv.jar

    Command-line sql JDBC tool

    jdbc2csv is a small command-line tool written in JAVA and can be used on all platforms, for which JRE 8 or higher is available. To connect to a specific DBMS the tool uses its JDBC driver. The result of the executed 'select' query is displayed in CSV format ( different standards are supported ). When there is an error the tool stops with exit code 1 and the error message is output on stderr. jdbc2csv is created with a main purpose to be used in shell-scripts. Relatively easy to configurate, this tool is suitable for queries ‘select’, ‘update’ and ‘delete’. I think that is not suitable for a large number of requests, like 'insert'.
    Leader badge
    Downloads: 117 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next