Open Source Linux Software Development Software

Browse free open source Software Development software and projects for Linux below. Use the toggles on the left to filter open source Software Development software by OS, license, language, programming language, and project status.

  • Veeam Data Platform v13.1 Icon
    Veeam Data Platform v13.1

    Move workloads across hypervisors and clouds with no vendor lock-in. Try VDP free today.

    Try Veeam Data Platform today. Experience the unified platform that's secure by design, portable by default, and proven to recover clean, fast, and anywhere.
    Try Now
  • Cut Data Warehouse Costs by 54% Icon
    Cut Data Warehouse Costs by 54%

    Easily migrate from Snowflake, Redshift, or Databricks with free tools.

    BigQuery delivers 54% lower TCO with exabyte scale and flexible pricing. Free migration tools handle the SQL translation automatically.
    Start Free
  • 1

    Expat XML Parser

    Fast XML parser library in C

    PLEASE NOTE that we are in the process of moving to GitHub: https://github.com/libexpat/libexpat This is James Clark's Expat XML parser library in C. It is a stream oriented parser that requires setting handlers to deal with the structure that the parser discovers in the document. PLEASE NOTE that we are in the process of moving to GitHub: https://github.com/libexpat/libexpat
    Leader badge
    Downloads: 1,117 This Week
    Last Update:
    See Project
  • 2
    a POSIX-C implementation of the http://oauth.net/ protocol. libOauth provides functionality to encode URLs and sign HTTP request data according to the oAuth standard.
    Leader badge
    Downloads: 4,765 This Week
    Last Update:
    See Project
  • 3
    gSOAP Toolkit

    gSOAP Toolkit

    Development toolkit for Web Services and XML data bindings for C & C++

    The gSOAP toolkit is an extensive suite of portable C and C++ software to develop XML Web services with powerful type-safe XML data bindings. Easy-to-use code-generator tools allow you to directly integrate XML data in C and C++. Serializes native application data in XML. Includes WSDL/XSD schema binding and auto-coding tools, stub/skeleton compiler, Web server integration with Apache module and IIS extension, high-performance XML processing with schema validation, fast MIME/MTOM streaming, SOAP and REST Web API development, WS-* protocols (WS-Security, WS-Policy, WS-ReliableMessaging, etc), XML-RPC and JSON. Licensed under GPLv2. Visit the developer center with guides, tutorials, and examples at www.genivia.com/dev.html The documentation of the toolkit, libraries, plugins and more is available at www.genivia.com/docs.html Commercial-use licenses and expert technical support services are available at competitive pricing levels, please visit www.genivia.com/products.html
    Leader badge
    Downloads: 627 This Week
    Last Update:
    See Project
  • 4
    sq data wrangler

    sq data wrangler

    sq data wrangler

    sq is a command line tool that provides jq-style access to structured data sources: SQL databases, or document formats like CSV or Excel. sq executes jq-like queries, or database-native SQL. It can join across sources: join a CSV file to a Postgres table, or MySQL with Excel. sq outputs to a multitude of formats including JSON, Excel, CSV, HTML, Markdown and XML, and can insert query results directly to a SQL database. sq can also inspect sources to view metadata about the source structure (tables, columns, size). You can use sq diff to compare tables, or entire databases. sq has commands for common database operations to copy, truncate, and drop tables.
    Downloads: 113 This Week
    Last Update:
    See Project
  • Earn up to 16% annual interest with Nexo. Icon
    Earn up to 16% annual interest with Nexo.

    Access competitive interest rates on your digital assets.

    Generate interest, borrow against your crypto, and trade a range of cryptocurrencies — all in one platform. Geographic restrictions, eligibility, and terms apply.
    Get started with Nexo.
  • 5
    An implementation of DSSSL, a style language to format SGML or XML documents. OpenJade contains backends for various formats (RTF, HTML, TeX, MIF, SGML2SGML, and FOT). This project also maintains OpenSP.
    Leader badge
    Downloads: 664 This Week
    Last Update:
    See Project
  • 6
    lxml

    lxml

    The lxml XML toolkit for Python

    A Python library for efficient XML and HTML processing, known for speed and compatibility. The lxml XML toolkit is a Pythonic binding for the C libraries libxml2 and libxslt. It is unique in that it combines the speed and XML feature completeness of these libraries with the simplicity of a native Python API, mostly compatible but superior to the well-known ElementTree API. The latest release works with all CPython versions from 3.6 to 3.12. See the introduction for more information about the background and goals of the lxml project.
    Downloads: 78 This Week
    Last Update:
    See Project
  • 7
    Rapid YAML

    Rapid YAML

    Library to parse and emit YAML, and do it fast

    Or ryml, for short. ryml is a C++ library to parse and emit YAML, and do it fast, on everything from x64 to bare-metal chips without operating system. (If you are looking to use your programs with a YAML tree as a configuration tree with override facilities, take a look at c4conf). ryml parses both read-only and in-situ source buffers; the resulting data nodes hold only views to sub-ranges of the source buffer. No string copies or duplications are done, and no virtual functions are used. The data tree is a flat index-based structure stored in a single array. Serialization happens only at your direct request, after parsing / before emitting. Internally, the data tree representation stores only string views and has no knowledge of types, but of course, every node can have a YAML type tag. ryml makes it easy and fast to read and modify the data tree.
    Downloads: 67 This Week
    Last Update:
    See Project
  • 8

    QuaZIP

    A C++/Qt ZIP library

    Moved to GitHub: https://github.com/stachenov/quazip
    Leader badge
    Downloads: 332 This Week
    Last Update:
    See Project
  • 9
    libmng -THE reference library for reading, displaying, writing and examining Multiple-Image Network Graphics. MNG is the animation extension to the popular PNG image-format.
    Leader badge
    Downloads: 1,300 This Week
    Last Update:
    See Project
  • Paessler: Easy to Use With Enterprise Power. Free Trial Icon
    Paessler: Easy to Use With Enterprise Power. Free Trial

    A low-code dashboard makes monitoring intuitive for any admin, while scripting and custom sensors give experts full control.

    You shouldn't have to choose between a monitoring tool that's easy to use and one that's powerful enough for a complex environment. PRTG's low-code interface lets any admin build dashboards, set alerts and monitor devices without scripting, while custom sensors and full API access are there when your team needs deeper control. One platform, no compromise. Download a free 30-day trial now.
    Get Free Download
  • 10
    Bootstrap

    Bootstrap

    HTML, CSS and JS framework for developing responsive websites and apps

    Bootstrap is an HTML, CSS, and JS framework designed for developing responsive, mobile first projects on the web. It's one of the most popular front-end frameworks and for good reason: it simply makes web development faster and easier. People of all skill levels can create projects of all sizes with Bootstrap, and for all types of devices too. With Bootstrap, you get a host of nifty features such as precompiled CSS, impressive scalability, dozens of custom HTML and CSS components and more.
    Downloads: 41 This Week
    Last Update:
    See Project
  • 11
    Grassroots DICOM

    Grassroots DICOM

    Cross-platform DICOM implementation

    Grassroots DiCoM is a C++ library for DICOM medical files. It is accessible from Python, C#, Java and PHP. It supports RAW, JPEG, JPEG 2000, JPEG-LS, RLE and deflated transfer syntax. It comes with a super fast scanner implementation to quickly scan hundreds of DICOM files. It supports SCU network operations (C-ECHO, C-FIND, C-STORE, C-MOVE). PS 3.3 & 3.6 are distributed as XML files. It also provides PS 3.15 certificates and password based mecanism to anonymize and de-identify DICOM datasets.
    Leader badge
    Downloads: 195 This Week
    Last Update:
    See Project
  • 12
    PDF4QT

    PDF4QT

    Open source PDF editor

    PDF4QT is open source PDF editor based on Qt framework. It contains a C++ library, applications for viewing/editing PDF documents, and a command line tool. PDF4QT is an open-source PDF editor for Windows/Linux. It is a modern solution for viewing/editing/rendering PDF documents, for users and developers alike. For developers, there is a C++ library and a command line tool for use in scripts. For users, there are four applications offering many features. The project is hosted on Github and uses the license LGPLv3. The applications are primarily used by target users to view, edit, manipulate or compare PDF documents. Users can preview these applications in the screenshots section of this webpage. Basic browsing and lots of other functionalities, such as encryption, reading a document, verification of digital signatures, editing of annotations, searching for text using regular expressions, drawing pages into an image, and much more. Several plug-ins are available.
    Downloads: 37 This Week
    Last Update:
    See Project
  • 13
    Tidy

    Tidy

    The granddaddy of HTML tools, with support for modern standards

    Tidy is a console application for macOS, Linux, Windows, UNIX, and more. It corrects and cleans up HTML and XML documents by fixing markup errors and upgrading legacy code to modern standards. libtidy is a C static and dynamic library that developers can integrate into their applications in order to bring all of Tidy’s power to your favorite tools. libtidy is used today in desktop applications, web servers, and more. Tidy tidies HTML and XML. It can tidy your documents by itself, and developers can easily integrate its features into even more powerful tools. Thanks for the efforts of HTACG and prominent contributors, HTML Tidy has a whole new heartbeat and a whole new life.
    Downloads: 31 This Week
    Last Update:
    See Project
  • 14
    Mercure

    Mercure

    Server-sent live updates, protocol and reference implementation

    Mercure is an open protocol for real-time communications designed to be fast, reliable and battery-efficient. It is a modern and convenient replacement for both the WebSocket API and the higher-level libraries and services relying on it. Mercure is especially useful to add streaming and asynchronous capabilities to REST and GraphQL APIs. Because it is a thin layer on top of HTTP and SSE, Mercure is natively supported by modern web browsers, mobile applications, and IoT devices. A free (as in beer, and as in speech) reference server, as well as a hosted service, are available. Designed for REST and GraphQL. Private updates (JWT authorization). Presence API and subscription events. Event store. Compatible with serverless, PHP, and the like. Supports end-to-end encryption. Reading the documentation is an excellent way to discover Mercure.
    Downloads: 29 This Week
    Last Update:
    See Project
  • 15
    OpenPDF

    OpenPDF

    open source Java library for creating and editing PDF files

    OpenPDF is a Java library for creating and editing PDF files with a LGPL and MPL open source license. OpenPDF is the LGPL/MPL open source successor of iText, and is based on a fork, of a fork, of iText 4 svn tag.
    Downloads: 26 This Week
    Last Update:
    See Project
  • 16
    Kile LaTeX Editor

    Kile LaTeX Editor

    Kile is a feature-rich LaTeX editor

    Kile is a LaTeX editor, a TeX shell that simplifies the creation of LaTeX documents.
    Leader badge
    Downloads: 120 This Week
    Last Update:
    See Project
  • 17
    gputils is a collection of tools for Microchip PIC microcontrollers. Its goal is to be fully compatible with Microchip's tools, MPASM, MPLINK, and MPLIB.
    Leader badge
    Downloads: 129 This Week
    Last Update:
    See Project
  • 18
    ArduinoJson

    ArduinoJson

    JSON library for Arduino and embedded C++. Simple and efficient

    ArduinoJson is a C++ JSON library for Arduino and IoT (Internet Of Things). ArduinoJson has a simple and intuitive syntax to handle objects and arrays. ArduinoJson supports both JSON serialization and deserialization. ArduinoJson uses a fixed memory allocation, allowing to work on devices with very little RAM. ArduinoJson can filter large inputs to keep only fields that are relevant to your application, thereby saving a lot of memory. ArduinoJson can parse directly from an input Stream or std::istream. ArduinoJson can produce compact or prettified documents. ArduinoJson works directly with strings stored in program memory. ArduinoJson supports two coding styles, with implicit or explicit casts. ArduinoJson deduplicates strings in the JSON document. When you have several identical keys or values, the JsonDocument only stores one of each. In practice, this feature reduces memory consumption by 20-30%.
    Downloads: 20 This Week
    Last Update:
    See Project
  • 19
    Nativefier

    Nativefier

    Make any web page a desktop application

    Tired of having to search through numerous open tabs on your browser just to view a web page that you regularly view? Make things easier and more convenient for yourself with Nativefier! Nativefier is a command-line tool that easily creates a desktop app for any web site with minimal configuration. It creates an Electron (which uses Chromium under the hood) based native wrapper in an OS executable (.app, .exe, etc) for use on Windows, macOS and Linux. Using Nativefier is absurdly simple. Just type in: nativefier "web site address" to create a native desktop app for your chosen web site, and Nativefier does the rest. It will automatically retrieve the app icon and name, which you can overwrite.
    Downloads: 20 This Week
    Last Update:
    See Project
  • 20
    XDXF - XML Dictionary Exchange Format
    XDXF is a project to unite all existing open dictionaries and provide both users and developers with universal XML-based format, convertible from and to other popular formats like Mova, PtkDic, StarDict, ABBYY Lingvo etc. * New drafts of format can be found here: https://github.com/soshial/xdxf_makedict/tree/master/format_standard * The development of dictionary converter moved to Github: https://github.com/soshial/xdxf_makedict
    Leader badge
    Downloads: 100 This Week
    Last Update:
    See Project
  • 21
    Twemoji

    Twemoji

    Simple library that provides standard Unicode emoji for all platforms

    Twitter’s open source emoji has you covered for all your project's emoji needs. With support for the latest Unicode emoji specification, featuring 3,245 emojis, and all for free. As an open source project, attribution is critical from a legal, practical and motivational perspective in our opinion. The graphics are licensed under the CC-BY 4.0 which has a pretty good guide on best practices for attribution. Although there are two kinds of parsing supported by this utility, we recommend you use DOM parsing, explained below. Each type of parsing accepts a callback to generate an image source or an options object with parsing info. The second kind of parsing is string parsing. This is unrecommended because this method does not sanitize the string or otherwise prevent malicious code from being executed; such sanitization is out of scope.
    Downloads: 19 This Week
    Last Update:
    See Project
  • 22
    Event Ruler

    Event Ruler

    Java library that allows matching many thousands of Events per second

    Event Ruler (called Ruler in the rest of the doc for brevity) is a Java library that allows matching Rules to Events. An event is a list of fields, which may be given as name/value pairs or as a JSON object. A rule associates event field names with lists of possible values. Event Ruler is a Java library that allows matching many thousands of Events per second to any number of expressive and sophisticated rules.
    Downloads: 18 This Week
    Last Update:
    See Project
  • 23
    Snappy PHP

    Snappy PHP

    PHP library allowing thumbnail, snapshot or PDF generation from an URL

    Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. It uses the excellent WebKit-based wkhtmltopdf and wkhtmltoimage available on OSX, Linux, Windows. You will have to download wkhtmltopdf 0.12.x in order to use Snappy.
    Downloads: 17 This Week
    Last Update:
    See Project
  • 24
    mPDF

    mPDF

    PHP library generating PDF files from UTF-8 encoded HTML

    mPDF is a PHP library that generates PDF files from UTF-8 encoded HTML. The original author, Ian Back, wrote mPDF to output PDF files ‘on-the-fly’ from his website, handling different languages. It is slower than the original scripts e.g. HTML2FPDF and produces larger files when using Unicode fonts, but support for CSS styles etc. and has been much enhanced. Supports almost all languages including RTL (Arabic and Hebrew), and CJK (Chinese-Japanese-Korean). Nested block-level elements (e.g. P, DIV) including margins, borders, padding, line height, background colors, etc. Right-to-left languages are supported, with automatic detection of RTL characters within a document. Transposes tables, lists, text justification, and table cell alignment, as well as a full-text reversal for RTL characters. Automatically detects non-RTL characters and displays these in the original order.
    Downloads: 17 This Week
    Last Update:
    See Project
  • 25
    PHP JWT Framework

    PHP JWT Framework

    JWT Framework

    This project is a framework that provides an implementation of JWS JSON Web Signature (RFC 7515), JWE JSON Web Encryption (RFC 7516), JWK JSON Web Key (RFC 7517), JWA JSON Web Algorithms (RFC 7518), JWT JSON Web Token (RFC 7519), JSON Web Key Thumbprint (RFC 7638), Unencoded Payload Option (RFC7797).
    Downloads: 15 This Week
    Last Update:
    See Project
  • Previous
  • You're on page 1
  • 2
  • 3
  • 4
  • 5
  • Next